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Creare una mappa con dati vettoriali

* QGis gestisce numerosi formati vettoriali e
raster. Il piu comune dato vettoriale e
sicuramente SHP — Shape ESRI.

=

® POINTS —

emmmmmmd | [NES

- \ 2
=
v POLYGONS — < ae 1




Creare una mappa con dati vettoriali

| filesin formato SHP sono in realta un insieme di files

SHP DBF SHX PRJ

> 8

SHP: contiene le informazioni grafiche

DBF: contiene i dati relativi ad ogni elemento grafico
(identificativo, tipologia, attributi vari)

SHX: e un file indice che collega SHP e DBF
PRJ: contiene le informazioni sul sistema di coordinate




Caricare dati vettoriali: SHP

Percorso: Layer-> Aggiungi vettore
O Icona da Barra degli Strumenti “Gestione Layer”

Rimuovi GPS
\ /
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Vettorlale \\
Raster

PostGIS

Aggiungi nuovo shp

ESERCIZIO

Inserire i seguenti file:
Confini amministrativi Regione “REG2015_WGS84.shp”
Vecchi “PROV1991_ WGS84.shp” e nuovi confini Provinciali “PROV2015 _WGS84.shp”

Confini amministrativi Comunali “COM2015_WGS84.shp”
‘Spegnere’ / ‘Accendere’ i singoli file .shp
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Muoversi nella mappa
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* Barra degli strumenti “Navigazione Mappa

Zoom suI layer Ultimo zoom
/

fé\ " () «— Aggiorna

Sposta mappa
Zoom in Zoom selezione
Zoom completo

Zoom out

* Per muoversi nella mappa sono utili gli strumenti della
“Navigazione mappa” la cui iconografia e simile a
qguella dei numerosi portali cartografici presenti in rete

* Le possibilita di muoversi nella mappa sono molteplici.
Ad esempio dal pannello Layer -> tasto destro -> Zoom
sul layer. Oppure dal menu Visualizza.



Muoversi nella mappa....

* Dopo aver caricato i file relativia Comuni,
Province e Regioni:

— Zoomare sulla Provincia di Trieste e
successivamente al Comune di Muggia

— Tornare alla visualizzazione precedente

— Zoomare sull’estensione completa del file relativo
alla Reg2015 WGS84



Spostarsi tra i layer vettoriali

¥, QGIS 2.14.1-Essi
Progetto Modifica Visualizza Layer Impostazioni Flugins Vettore Raster Database Web MMQGIS —Guids
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Spostarsi tra i layer vettoriali
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Attivare/Disattivare layer vettoriali
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Etichettare i layer vettoriali (layer > etichettatura)

Modalita = Show |abels for this layer 3

&
Campo Etichetta con | abe NOME -

W Testo/Contorno campione

Lorem Ipsum

Lorem Ipsum

abe Testo Stile di testo
+ab -
= ¢ Formattazion Carattere MS Shell Dig 2

abe Contorno

. Sfendo Stile Mormal
J Ombra

'1':* Pusizi:}nameltn @ @

__,‘" WVizualizzaziofe ) )
Dimensione 38,2500

Stile

Colore [

Trasparenza C

Tipo maiuscolo | Messun cambiamento
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Etichettare i layer vettoriali (layer > etichettatura)

7 QGIS 2.14.1-E

Progetto Modifica Visualizza Layer Impostazioni Plugins Vettore Raster Database Web MMQGIS Guida
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La tabella Attributi

Percorso: Layer -> Apri Tabella attributi

Oppure: cliccare con il destro sul layer e selezionare “Apri Tabella Attributi”

ID progressiv

Bl aZ28e$ Pt B
OBJECTID - COD_REG MOME Shape_Leng Shape_Area
i} “ 1 1 Dmﬂ-\: 1'1'1'wﬂ Tﬁ'mm il
il 2 2 |Valle D'Aosta 325833.7505810... | 3260902116.949...
B 3 3 |Lombardia 1511143.074440... | 23863449799,90...
& 4 4 | Trentino-Alto Adige | 859879,2771509... | 13604915800.89. ..
4 5 5 [veneto 1146942.963560... | 18407272451.79 .
5 & & | Friuli Venezia Giulia | 77014&,3930890... | 7862266855.520...
5 7 7 |Liguria 1080315.627540... | 5416218657.319..
7 8 8 | Emilia-Romagna 1260958.599379... | 22452552904.59 ...
3 9 9 | Toscana 1545218, 220770... | 22986947637.70...
g 10 10 [Umbria 671132.7137360... | 8464251163.149 ..
10 11 11|Marche 711087, 1717280... | 9401333626.950...
11 12 12 [Lazio 1201436.093769... | 17232123330,29...
12 13 13 | Abruzzo 664543.5413089... | 10831675349.00...
13 14 14 | Molise 471201.56151640... | 4460512062.579..
14 15 15 | Campania 1090762.873419... | 13670835248.20...
15 16 16 | Puglia 1507355,366050... | 19540853688,50...
16 17 17 | Basilicata 675756.8737719... | 10073287546.60...
17 I 18 18 | Calsbria 934666..2538509... | 15221895218.89 ..
18 19 19 | Sicilia 1731345.851740... | 25832399994.50...
20 20 | Sardegna 2128481.993259... | 24100139070.09...

b § Mostra tutti gli elementi -

Campi




Tabella Attributi

Editing sulla tabella attributi:

1) Inserire nuovi campi;
2) Eliminare campi;

3) Inserire dati;

4) Creare campi derivati;
5) Creazione di Query;
6) Join tra tabelle di dati
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iNUSC Ricerca avanzata ?
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Strumenti editing Strumenti di Query
Tabella

Mostra SO}! I selezionat
'A
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Strumenti azione
su elementi
selezionati



La tabella Attributi: strumenti disponibili

Avyia la ' Strumgnti di Strumenti di Aggiungi/Elimina
sessione di selezione visualizzazione Campo
modifica

Calcolatore di

Salva le i
- campi
modifiche
S JJabella Aﬂﬁhuﬁ -
o M F o ’ T = = ' l"_h — -
[y ] = D [ I & {4 E I I - ;""J I [ | g
| | OBIECTID COD_REG COD_PRO NOME SIGLA Shape_Leng Shape_Area
0 1 ¢ T T g
. 2 / 1 2 vercell VC 458757.8478129 | 2081632395, 140
B 3 1 3 |Novara NO 276724.3307609... | 1340269555.680. ..

Importare “Reg2015_WGS84.shp”

Cliccando sul nome campo Creare un nuovo campo “Capoluogo”

ordine crescente/decrescente Inserire i nomi dei capoluoghi

Salvare la nuova tabella

ke W

Etichettare I'elemento grafico con i capoluoghi di
regione




Gestione dell’interfaccia grafica: i pannell
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File Modifica | Visualizza | Layer Impostazioni Plugins Database Vettore Raster Guida
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Misura L] 5]
-{ Zoom completo Ctrl+Shift+F

‘wt. Zoom sul layer
':{ Zoom alla selezione Ctrl+)
®, Ultimo zoom

Zoom successi

Zoom alla dimensione corrente
Suggerimenti mappa

Maostra segnalibri Ctrl+Shift+B
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=
3 Muove segnalibro..
&
o

Aggiorna Ctrl+R
Slider per scala delle tiles

Tracciamento GPS in tempo reale

P X Layer
Barre degli strumenti L4 Pancramica
Schermo Intero Ctrl+F Annulla/Ripristina

Cattura coordinate

Via pid breve
Openlayers Overview
Storice modifiche O5M
Elemento O5M

© QGIS 20!
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Gestione dell’interfaccia grafica: le barre degli strumenti

Z Quantum GIS 1.7.4-Wracl

File Modifica | Visualizza | Layer Impostazioni Plugins Database Vettore Raster Guida
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¥

¥ Sposta mappa

';%, Ingrandisci Ctrl++

(_:{' Rimpicciolisci Ctrl+-
Seleziona

Y Informazioni elementi Ctrl+Shift+I
Misura

£ Zoom completo Ctrl+Shift+F

. Zoom sul layer
Q Zoom alla selezione Ctrl+J
@‘{' Ultimo zoem
2 Zoom successivo
i, Zoom alla dimensione corrente
@ Suggerimenti mappa
& Nuovo segnalibro...
" Mostra segnalibri Ctrl+Shift+B
(2) Aggiorna Ctrl+R
Slider per scala delle tiles
Tracciamento GPS in tempo reale
Pannelli
deg

Schermo Intero Cirl+F
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X/ File
X Gestione layer
X Digitalizzazione
X Digitalizzazione avanzata
¥ Mavigazione mappa
| Attributi
¥ Plugin
Guida
® Raster
X Etichetta
x| GRASS
X Dimensioning
X Rectangles, ovals digitizing tools
X OpenStreetMap
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Lavorare con i Plugin

Percorso: Plugins -> Gestione Plugins

' Plugin | Tutto (388)

h Tutto

| & |
F -: Installato

Mon installati

r'ﬁ' Aggiornabile

ﬁ Impaostazioni

* Affine Transformations

* ArcGIS REST API Connector
* ArcheoCAD
* Area Along Vector

" autoSawver
* AutoTrace

* Circuitscape for Processing
s ClicksFu [Agginrna h.ltto] [Disinstalla il plugin] [

* Accuracy Assessment Tutti i plugin
* AccurAssess

Sulla sinistra puoi vedere una lista di tutti i plugin
disponibili per QGIS, sia quelli gia installati che quelli
» AniMove for QGIS scaricabili. Alcuni plugin sono inclusi nell'installazione
di QGIS, ma la magagior parte € disponibile attraverso

i repositories.

* Azimuth and Distance Calcu
* Azimuth and Distance Plugir
* beePen

* BLM Exporter

* Buffer by Percentage

* Bulk vector export

* cadastre

* CADDigitize

* CadTools

* Calcarea

- Cattura coordinate

12| = |

Puoi attivare o disattivare temporaneamente un
plugin. Per attivare o disattivare un plugin, clicca sulla
" Arrows casella di controllo o fai doppio click sul suo nome...
Astrageology POW I plugin in rosso non sono caricati percheé & sorto un
* Attribute painter problema. Questi vengono anche elencati nella
scheda 'Non valido'. Clicca sul nome del plugin per
maggiori dettaagli, per reinstallarlo o disinstallarlo.

Reinstalla plugin

Close Help




Gestione dei Plugins

* Scorrere la lista dei Plugin di “Gestione Plugin”
e spiegarne le funzionalita principali

* |nstallare i seguenti Plugin:

1. Table manager (per la gestione della tabella attributi)

2. Statist (per elaborazione di statistiche piu
‘complicate’)

3. OpenlLayer Plugin (per accedere online ai principali
portali cartografici)



Lavorare sulla Tabella attributi:
inserire nuovi campi ed eliminare campi

* Due possibilita:
1. Lavorare con gli strumenti della tabella attributi;
2. Attivare il Plugin “Table manager”

Da Tabella Attributi:

— Da Tabella Attributi, in fase di editing, e possibile inserire colonne
(supportata dalla libreria OGR). Icona |

— Da Tabella Attributi, in fase di editing, e possibile anche eliminare
colonne



Lavorare sulla Tabella attributi:
inserire/rinominare/eliminare campi

Da Vettore > Plugin
“Table manager”:

Strumento di
immediata
comprensione che
permette una
gestione agile dei
layer .shp

Tuttavia esso non
permette di creare
campi derivati.

| Table Manager: Prov2011_WG584

Fields Table preview

i e e e e e

MName Type
QBJECTID Integer(9)
COD_REG Integer(d)
COD_PRO Integer(9)
MOME String(58)
SIGLA String(5)
Shape_Leng Real(18,11)
Shape_Area Real(18,11)




Salvare i dati

Cosa significa salvare i dati in un GIS?

1. Salvare le modifiche fatte sui singoli file (shp, kmz,
dxf, geotiff..).

2. Salvare il progetto, ossia la visualizzazione a mappa
dei layer (vettoriali/raster). In questo caso si crea un
nuovo ‘file di collegamento’. Se verranno le singole
posizioni dei file sulla memoria, alla riapertura
comparira esattamente la stessa visualizzazione.



1. Salvare le modifiche su singolo file

Scelta del formato "/ salvai vettori come.. P =
(shp, dxf, gml, kmz, etc)  —— —
Formato ESRI shapefile -
h—

Salva con nome

Sfoglia
Nome e posizione in memoria PC —

/ Sistema di riferimentd | SR selezionato (EPSG: 32632, WES 84 -
Sistema di Coordinate

Codifica System B

T e e T B e
X Aogiungi il file salvato sulla mappa
Possibilita di salvare

Esporta simbologia Messuna simbologia -
solo gli elementi selezionati S =)
(si crea un nuovo file grafico!)

¥ Geometria

Tipo di geometria Automatico

[] Force multi-type
[ indude z-dimension
Layer > Salva con nome b [ Estensione (attuale: vettore) |
o) w Opzioni del layer
RESIZE MO bl o
Menu contestuale > Salva con nome ot (oS =iz




1.Salva vettori come...

Formato ESRI shapefile
Salva con nome

Sistema di riferimento | SR selezionato (EPSG:32632, WGS 84 / UTM zone 32M)

Codifica System

Salva solo le geometrie selezionate
Salta la creazione degli attributi

| Aggiungi il file salvato sulla mappa

Esporta simbologia Messuna simbologia

Scala 1:50000

> Estensione (attuale: vettore)

IE Opzioni su origine dati

B Opzioni del layer

P Opzioni personal lizzate

Help

Porre particolare
attenzione a DOVE si
salvall

Attivare la voce ‘Salva
solo le geometrie
selezionate’

Scegliere formato e
sistema di riferimento
(riproiezione!!!)



2. Salvare ed esportare il progetto per la stampa

 Dal menu “File” -> “Nuova composizione di Stampa”

 Barra degli strumenti -> “File”

Nuovo progetto —— | = 4 4 - _'

\Stampa
— 1

Apri progetto Nuova composizione
Salva progetto di stampa

* |l progetto consiste in un insieme di layer e viene salvato con
la visualizzazione in atto. || formato con cui viene salvato un
progetto e .qgs

* Per esportare il progetto 2 modalita:

 Semplice: File -> “Salva come immagine”

* Piu elaborato: File -> “Nuova composizione di stampa”



Nuova composizione di stampa

. Dal menu “layout” -> “Aggiungi mappa” e “Aggiungi legenda vettoriale”
. Possibilita di salvare in jpg, pdf o svg oppure Stampare

File Visualizza Layout

AEdsPe s RAAOnrRudEap\NEv/o s 8 @B

Generasle | Oggetto | Storico dei comandi |
Composizione [Mappa 1
~Carta e qualita

Dimensione
| A4 (210x297 mm) v
Unita
|mm v
| Larghezza 297,00 =
| Altezza 210,00 £
Direzione
(o I~
{Quaits 300 B
|| Stampa come raster
Snapping
|| snap alla grigiia
| Spaziatura 0,00 1=
| Offset X 0,00 =]
| Offset Y 0,00 =
| Larghezza tratto 0,50 EJ‘
Colore griglia
|
Stile griglia
|Punt v




Nuova composizione di stampa

T IR
Exportimage Export SVG

Export PDF

Quality 3
[ Print 2

Spacing L

-
X offset o

&

4



Nuova composizione di stampa

ESERCIZIO

* Creare la mappa della Comuni della Provincia di
Trieste

e Salvare come pdf



