. Introduction to Simulation
('ntel) FPGA of VHDL Designs

For Quartus® Prime 18.1

1 Introduction

An effective way of determining the correctness of a logic circuit is to simulate its behavior. This tutorial provides
an introduction to such simulation using the Intel® Quartus® Prime CAD system.

The simulation method used in this tutorial is based on drawing waveforms, similar to timing diagrams, that are
inputs for a simulator tool. The outputs of the simulator are also in the form of waveforms. This tutorial is intended
for students who are taking a course in logic circuit design. We show how to use the Simulation Waveform Editor
tool provided in the Quartus Prime software to perform a simulation of a circuit specified in VHDL HDL. Only a
very basic understanding of VHDL is needed for this purpose.
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The Simulation Waveform Editor tool is available for use with Intel’s Quartus II software version 13.0 or later. It
allows the user to apply inputs to the designed circuit, usually referred to as test vectors, in the form of waveforms
and to observe the outputs generated in response.

In this tutorial, the reader will learn about:

* Test vectors needed to test the designed circuit
* Using the Simulation Waveform Editor tool to draw test vector waveforms
* Functional simulation, which is used to verify the functional correctness of a synthesized circuit

* Timing simulation, which is used to verify the timing of signals in a synthesized circuit

This tutorial is aimed at the reader who wishes to simulate circuits defined by using the VHDL hardware description
language. An equivalent tutorial is available for the user who prefers the Verilog language.

2 Design Project

To illustrate the simulation process, we will use a very simple logic circuit that implements the majority function of
three inputs, x;, x» and x3. The circuit is defined by the expression

F(x1, %2, X3) = X1X2 + X1 X3 + X2X3

In VHDL, this circuit can be specified as follows:

LIBRARY ieee;
USE ieee.std_logic_1164.all;
ENTITY majority3 IS
PORT ( x1, x2, x3 : 1IN STD_LOGIC;
f: OUT STD_LOGIC) ;
END majority3;

ARCHITECTURE majority3_rtl OF majority3 IS
BEGIN

f <= (x1 AND x2) OR (x1 AND x3) OR (x2 AND x3);
END majority3_rtl

Implement this circuit as follows:

* Create a project majority3.

* Include a file majority3.v, which corresponds to the VHDL snippet above.
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* Select the correct device that is associated with your DE-series board. A list of device names for the DE-series

boards can be found in Table 1.

* Compile the design.

Board Device Name
DEO-CV Cyclone® V 5CEBA4F23C7
DEO-Nano Cyclone® IVE EP4CE22F17C6
DEO-Nano-SoC | Cyclone® V SoC 5CSEMA4U23C6
DEI1-SoC Cyclone® V SoC 5SCSEMASF31C6
DE2-115 Cyclone® IVE EP4CE115F29C7
DE10-Lite Max® 10 10M50DAF484C7G
DE10-Standard | Cyclone® V SoC 5SCSXFC6D6F31C6
DE10-Nano Cyclone® V SE 5CSEBA6U2317

Table 1. DE-series FPGA device names

3 Creating Waveforms for Simulation

To create test vectors for your design, select File > New... > Verification/Debugging Files > University Program
VWEF in the Quartus Prime window where the design project is open. This opens the Simulation Waveform Editor

tool, shown in Figure 1, which allows you to specify the desired input waveforms.
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Figure 1. The Waveform Editor window.
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For our simple circuit, we can do a complete simulation by applying all eight possible valuations of the input signals
X1, X2 and x3. The output f should then display the logic values defined by the truth table for the majority function.

We will run the simulation for 800 ns; so, select Edit > Set End Time... in the Waveform Editor and in the pop-up
window that will appear specify the time of 800 ns, and click OK. This will adjust the time scale in the window of
Figure 1.

Before drawing the input waveforms, it is necessary to locate the desired signals in the implemented circuit. In
FPGA jargon, the term “node” is used to refer to a signal in a circuit. This could be an input signal (input node),
output signal (output node), or an internal signal. For our task, we need to find the input and output nodes. This is
done by using a utility program called the Node Finder.

In the Waveform Editor window, select Edit > Insert > Insert Node or Bus.... In the pop-up window that appears,
which is shown in Figure 2, click on Node Finder.

rG Insert Mode or Bus L&r
Name: Ok
Type: INPUT hd cancel
Walue type: B—Le'.rel—v
T Binar)r—v Node Finder...
Bus width: 1
Start index: 0
Display gray code count as binary count

W 4

Figure 2. The Insert Node or Bus dialog.

The Node Finder window is presented in Figure 3. A filter is used to identify the nodes of interest. In our circuit,
we are only interested in the nodes that appear on the pins (i.e. external connections) of the FPGA chip. Hence, the
filter setting should be Pins: all. Click on List, which will display the nodes as indicated in the figure. In a large
circuit there could be many nodes displayed. We need to select the nodes that we wish to observe in the simulation.
This is done by highlighting the desired nodes and clicking on the > button. Select the nodes labeled x/, x2, x3, and
/, which will lead to the image in Figure 4. Click OK in this window and also upon return to the window in Figure 2.
This returns to the Waveform Editor window, with the selected signals included as presented in Figure 5.
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Figure 3. The Node Finder dialog.

- ~
i MNode Finder @
Named: * Fiter: | Pins: all [ ok ]
Lookin: * E] [ List ] [ Cancel ]

Nodes Found: Selected Nodes:
Name Type N:;me Type
out f iOutput out f Output
- i h -
iﬁ_ x1 Input Q_ =1 Input
iﬁ_ x2 Input ﬂ_ =2 Input
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Figure 4. The selected signals.

Observe that in Figure 5 all input signals are at logic level 0. The output, fis shown as undefined. Next, we have to
draw the input waveforms. Then, we will simulate the circuit, which will produce the output waveform.

To make it easier to draw the input waveforms, the Waveform Editor displays dashed grid lines. The spacing of the
grid lines can be adjusted by selecting Edit > Grid Size..., and in the pop-up box in Figure 6 specifying the desired
size. The spacing of grid lines in Figure 5 is 20 ns. Another convenience in drawing is to have transitions of a
waveform snap on grid lines. This feature is activated by clicking on the Snap to Grid icon

command Edit > Snap to Grid.
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Figure 5. Signals in the Waveform Editor window.
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Figure 6. Specifying the grid spacing.

Input waveforms can be drawn in different ways. The most straightforward way is to indicate a specific time range
and specify the value of a signal. To illustrate this approach, click the mouse on the x/ waveform near the 400-ns
point and then drag the mouse to the 800-ns point. The selected time interval will be highlighted in blue, as depicted
in Figure 7. Change the value of the waveform to 1 by clicking on the Forcing High (1) icon ™, as illustrated in

Figure 8.
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Figure 7. Selection of a time interval.
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Figure 8. Drawing the waveform for x/

In creating the waveform for xJ, we used the icon ** to implement the logic value 1. Another possibility is to invert
the value of the signal in a selected time interval by using the Invert icon # . We will use this approach to create
the waveform for x2, which should change from O to 1 at 200 ns, then back to 0 at 400 ns, and again to 1 at 600 ns.

Select the interval from 200 to 400 ns and click on the icon. Then do the same for the interval from 600 to 800 ns,
as illustrated in Figure 9.

Intel Corporation - FPGA University Program

March 2019


https://www.altera.com/support/training/university/overview.html

INTRODUCTION TO SIMULATION OF VHDL DESIGNS For Quartus® Prime 18.1

f - JE— ™
& Simulation Waveform Editor - Di/simulation_intro/majority3 - majority3 - [Waveform.wf]* - [ =T[CT éj
Fie Edit Wiew Simulation Hep @ Search attera.com Q

[0 oo
Ha %8 % Z)0E)E W IEE B IR W2l 2 (=8
Master Time Bar: 0 ps E E] Pointer: 712.55 ns Interval: 712.55 ns Start: 600.0 ns End: 200.0 ns
-
Value at 0ps 1GD.ID ns 320'.0 ns 4BU.ID ns G40.ID ns 200.0 ns
Name Ops 0ps
| |
I BX
o ox BO |
B e 80 |
L a3 BO
4 [ 4 1 ()
0% 00:00:00
\ = J

Figure 9. Drawing the waveform for x2.

We will use a third approach to draw the waveform for x3. This signal should alternate between logic values 0 and
1 at each 100-ns interval. Such a regular pattern is indicative of a clock signal that is used in many logic circuits.
Even though there is no clock signal in our example circuit, it is convenient to specify x3 in this manner. Click on
the x3 input, which selects the entire 800-ns interval. Then, click on the Overwrite Clock icon "% as indicated in

Figure 10. This leads to the pop-up window in Figure 11. Specify the clock period of 200 ns and the duty cycle of
50%, and click OK. The result is depicted in Figure 12.
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Figure 10. Drawing the waveform for x3.
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Figure 11. Defining the clock characteristics
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Figure 12. The completed input waveforms.

Save the waveform file as Waveform.vwf. Note that the suffix vwf stands for vector waveform file. VWF files that are
added to the Quartus Prime project can be accessed at any time in the Project Navigator Widget’s Files tab.

4 Simulation

The Simulation Waveform Editor performs the simulation by using the simulation tool known as ModelSim. ModelSim-
Intel Edition is strongly recommended for use with the Simulation Waveform Editor, as it contains the Intel device
libraries necessary for simulations. To use a standard version of ModelSim, the path to its executables must be
specified in the Quartus Prime software under Tools > Options... > EDA Tool Options. If both ModelSim and
ModelSim-Intel are available, the simulator will preferentially use ModelSim-Intel.

4.1 Functional Simulation

Now that we have created the input vector waveform, we can simulate the circuit. In the Simulation Waveform
Editor, select Simulation > Run Functional Simulation, or click on the icon *in. A pop-up window will show
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the progress of the simulation, then automatically close when it is complete. A second Simulation Waveform Ed-
itor window then opens the output waveform, as depicted in Figure 13. The output waveform is read-only, so any
changes in simulation have to be done by modifying the Waveform.vwf file and resimulating the circuit. Observe that
the output fis equal to 1 whenever two or three inputs have the value 1, which verifies the correctness of our design.

r ~
(G Simulation Waveform Editor - Di/simulation_intro/majority3 - majority3 - [majority3_20150904154318.sim.vwf (Read-Only)] (=] B [
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e = = —= = =
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Figure 13. Result of the functional simulation.

4.2 Timing Simulation

To observe the actual propagation delays in our circuit, we have to perform a timing simulation. (Note that for FPGA
devices with preliminary timing models that the timing simulation results may be the same as functional simulation
results.) In the Simulation Waveform Editor, select Simulation > Run Timing Simulation, or click on the icon my
A pop-up window will show the progress of the simulation, then automatically close when it is complete. A second
Simulation Waveform Editor window then opens the output waveform. The output waveform is read-only, so any
changes in simulation have to be done by modifying the Waveform.vwf file and resimulating the circuit.

The timing simulation shows that there are delays when signals change from one value to another. Figure 14 shows
the waveform, zoomed in at 300 ns to show the propagation delay between x3 and f. The waveform indicates that
the maximum delay is approximately 6 ns.

Note: timing simulations are only supported by Cyclone® IV and Stratix® IV FPGAs. If your Quartus project is
not setup for a Cyclone IV or Stratix IV device, the result of running a timing simulation will be identical to the
functional simulation.
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Figure 14. Result of the timing simulation, zoomed in at 300ns.

5 Making Changes and Resimulating

Changes in the input waveforms can be made using the approaches explained above. The circuit can then be resimu-
lated using the altered waveforms. For example, change the waveform for x; to have the logic value 1 in the interval
from 100 to 240 ns, as indicated in Figure 15. Now, simulate the circuit again. The result is given in Figure 16. If

errors in the circuit are discovered, then these errors can be fixed by changing the VHDL code and recompiling the
design using the Quartus Prime software.
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Figure 15. Modified input waveforms.
Intel Corporation - FPGA University Program 11

March 2019


https://www.altera.com/support/training/university/overview.html

INTRODUCTION TO SIMULATION OF VHDL DESIGNS

For Quartus® Prime 18.1

I ~
(0% Simulation Waveform Editor - Di/simulation_intro/majority3 - majerity3 - [majority3_20150904160459.sim.vwf (Read-Only)] =
File Edit Miew Simulation Help L] Search altera.com e

e X & & ZEE B HEE E IR 2 e 4 @
Master Time Bar: 0 ps E E] Pointer: 712.55 ns Interval: 712.55 ns Start: End:
-
Name Value at 0ps 1GD.ID ns 320'.0 ns 4BU.ID ns G40.ID ns 200.0 ns
Ops 0ps
out f B U
- |
B x BO
A 80 | |
L a3 BO
4 [ 4 1 L S

0%

00:00:

oo

Figure 16. Result of the new simulation.

6 Concluding Remarks

The purpose of this tutorial is to provide a quick introduction to the Simulation Waveform Editor, explaining only
the rudimentary aspects of functional and timing simulations. Details about additional features of the Simulation
Waveform Editor can be found in the appendix of this document.

To learn about more about simulating circuits using ModelSim, please refer to the tutorial Using ModelSim to
Simulate Logic Circuits, which is available on Intel’s FPGA University Program website.
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A Simulation Waveform Editor

In section 3 we introduced the Waveform Editor tool, which is used to view and edit waveforms that are used in
simulation. Additional features of the Waveform Editor are described in this appendix.

A.1  Waveform Editor Toolbar

The Waveform Editor window is illustrated in Figure 1. The tool includes several commands which can be accessed
by using the mouse, including File, Edit, View, Simulation, and Help. Below these commands, as shown in the
figure, there is a toolbar that contains a number of icons which are useful when manipulating waveforms. This
toolbar should be visible by default, but if it is not visible, then right-click near the top of the window (below the
title bar) and select Waveform Editor in the menu that appears.

The toolbar icons are described below.

Selection Tool [&]
This tool is used to select waveform intervals and apply changes. To make a selection, click on any part of a
waveform and drag the blue box across the desired interval. It’s possible to select multiple waveforms at the
same time, as shown in Figure 1, or select entire waveform(s) by clicking on its name(s).

I ~
I Simulation Waveform Editor - Di/simulation_intro/majority3 - majority3 - [majority3.vwil* = | B S
File Edit Wiew Simulation Help @ Search attera.com O

M & & & 2 )EE B IET 0 )E &2 4 B
Master Time Bar: 0 ps 4 * | Pointer: 77865 ns Interval: 778.55 ns Start: 380.0 ns End: 720.0 ns
0ps 160.0 ns. 320.0 ns 430.0 ns. 540.0 ns. 800.0ns *
Name Value at ' ' ' '
Ops 0ps
@l of BX
B xt BO
B = BO I
B = BO
L
4 [ 4 LIS L S
L 100% 00:01:52

Figure 1. Using the Selection Tool to select a portion of multiple waveforms.

Double clicking the selection tool anywhere on a waveform will select the largest interval with the same value
from where the cursor points. Double clicking on a selected interval brings up the window to set arbitrary
values for that interval.

Zoom Tool
This tool is used to zoom in or zoom out in the waveform display, as indicated in Figure 2. Left-clicking
zooms into the display and right-clicking zooms out.
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Figure 2. Using the Zoom Tool.

Forcing Unknown(X)

This tool allows the selected part of a waveform to be set to the value Unknown (x). An example is given in
Figure 3, using the majority3 function circuit that was described in section 2. The value of the signal x3 has
been set to unknown for the first half of the simulation. Running the simulation with these input values results
in the output waveform f that is shown in the figure. Note that the value of fis unknown between 200 to 400

ns.
e 1
(0% Simulation Waveform Editor - Di/simulation_intro/majority3 - majority3 - [majority3_20150904162605.sim.vwf (Read-Only)] =
File Edit Miew Simulation Help L] Search altera.com e
e X & & ZEE B HEE E IR 2 e 4 @
Master Time Bar: 0 ps E E] Pointer: Interval: Start: End:
=
Name Value at 0ps 1GD.ID ns 320'.0 ns 4BU.ID ns G40.ID ns 200.0 ns
Ops 0ps Il
N
T f BO
o ox BO |
B = B0 | |
L a3 B X
4 [ 4 1 al | [
0% 00:00:00
.

Figure 3. Setting the value of an input to Unknown (X).

Forcing Low (0)  and Forcing High(1) ™

These tools are used to force the selected part of a waveform to the value low (0) or high (1), as shown in

Figures 4 and 5, respectively.
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Figure 4. Forcing x; to be low from 0 to 400 ns.
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Figure 5. Forcing x; to be high from 400 to 800 ns.

High Impedance (Z) =
This tool forces the selected waveform to the value High Impedance (Z), as shown in Figure 6. The high
impedance value represents a signal that has not been set to any specific value—that is, an input pin that

is not connected. Forcing output waveforms to have high impedance does not affect the output simulation
waveforms.
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Figure 6. Setting a signal to high impedance.

Weak Low (L) #= and Weak High (H) /&
These tools are used to set a signal to the values Weak Low (L) or Weak High (H), which

represents a circuit

in which a bidirectional signal is pulled down or up by using a resistor. Examples are shown in Figures 7 and

r ~
W Simulation Waveform Editor - Di/simulation_intro/majority3 - majority3 - [majority3.vwil* =NECE X
Fie Edit Wiew Simulation Help @ Search attera.com Q
(a2 & A £[EE % )E8 6 & xt 2 @5
Master Time Bar: 0 ps Interval: 23257 ns Start: 200.0 ns End: 400.0 ns
-
Name Value at 0ps 1GD.ID ns 320'.0 ns 4BU.ID ns G40.ID ns 200.0 ns
‘ 0ps 0 ps
£ f BX
L = BO i L v
e = B0 | | |
L a3 BO
4 IR 1 | » -
Overwrite Weak Low 100% 00:01:52

Figure 7. Changing the x/ signal to be weak low from 200 to 400 ns.
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W Simulation Waveform Editor - Di/simulation_intro/majority3 - majority3 - [majority3.vwil* =NECE X
Fie Edit Wiew Simulation Hep @ Search attera.com Q

[0 oo
e & 4 2 X)a E 8 2 )E & x% B
Master Time Bar: 0 ps VWeak High (H) ter: 15.85 ns Interval: 15.85 ns Start: 400.0 ns End: §00.0 ns
B
Name Value at 0ps 1GD.ID ns 320'.0 ns 4BU.ID ns G40.ID ns 200.0 ns
Ops 0ps
\RETSE BX |
o ox BO { H b
B x B0 | |
m x3 BO I
o
I 4 b 4 1 L S
Overwrite Weak High 100% 00:01:52
—— = — ——

Figure 8. Changing the x/ signal to be weak high from 400 to 600 ns.

Invert #
This tool inverts the value of a selected waveform, as shown in Figure 9. Low signals become high, weak low
signals become weak high, and vice versa for both cases. The Invert tool has no effect on a signal that is set
to high impedance or unknown.

I ~
(% Simulation Waveform Editor - D:/simulation_intro/majority3 - majority3 - [majority3.vwil* =RREN X
File Edit View Simulation Help @ Search altera.com ®

(R e A 2)EERIET2E & x4 B
Master Time Bar: 0 ps <| Invert E Pointer: 31.73 ns Interval: 31.73 ns Start:  100.0 ns End: 250.0 ns
-
Name Value at Ops 1GD.ID ns 320'.0 ns 4BU.ID ns G40.ID ns 800.0 ns
Ops 0ps
@l of BX
B x BO
e x B0 | | |
B BO
4 b 4 L8 (|
Ll Owverwrite Invert 100% 00:01:52
J

Figure 9. Inverting the x/ signal from 100 to 260 ns.

Count Value *€
This tool allows a waveform to be partitioned into sections, in which the value is incremented by a specified
amount. The Count Value tool can only be applied to a single waveform or a grouped waveform (see section
B.1). The options that are available when using the Count Tool are illustrated in Figure 10.
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- -
il Count Value @

Radix: Binary - ]

Start value: ]
Increment by: 1
Count type
@) Binary

(©) Gray code
Transitions occur

Count every: 100.0

[ 0K J[ Cancel ]

L 4

Figure 10. Options available for for the Count Value tool.

As an example, Figure 11 shows the 3-bit input signal called count set to increment by one every 100 ns.

r 1
W Simulation Waveform Editor - Di/simulation_intro/majority3 - majority3 - [majority3.vwil* =HECE X
Fie Edit Wiew Simulation Help @ Search attera.com Q
& % 0 A Z ) E 3 CE 26 2 x4 B
Master Time Bar: 0 ps E E] Pointer: 583.17 ns Interval: 583.17 ns Start: 0ps End: 200.0 ns
-
Name Value at 0ps 1GD.ID ns 320'.0 ns 4BU.ID ns G40.ID ns 200.0 ns
| 0ps Ups I
il T
B v m B 000 ST ST ST T T T
4 K [ | -
100% 00:01:52

Figure 11. An example of using the Count Value tool.

Overwrite Clock *&
This tool is used to generate a periodic waveform, which is often used as a clock signal. The options available
when using the Overwrite Clock tool are shown in Figure 12.
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(G Clock =)
Base waveform on time period
Period: | 200.0 ns hd
Offset: 0.0
Duty cycle (%) 50 2
[ 0K ] [ Cancel ]
\

S

Figure 12. Options available for the Overwrite Clock tool.

In the example of Figure 13, the x3 signal has been generated with a period of 200 ns, an offset of 0 ns, and a

duty cycle of 50%.
r ~
(# Simulation Waveform Editor - Di/simulation_intro/majority3 - majority3 - [majority3.vwil* SNIEN X
Fie Edit Wiew Simulation Help @ Search attera.com Q
(& % 0 A Z ) E 3 OC 8 26 2 x4 [E5
Master Time Bar: 0 ps E E] Pointer:  1.32 ns Interval: 1.32 ns Start: 0ps End: 200.0 ns
|
-
" Value at 0ps 1GD.ID ns 320'.0 ns 4BU.ID ns G40.ID ns 200.0 ns
[ ame 0ps 0ps
G BX
LI BO ' {
- % B0 | | |
- | VO O e WO i
4 SIEN 1 [ &

Arbitrary Value 2

100%

Figure 13. An example of using the Overwrite Clock tool.

00:01:52

This tool allows a signal to be set to an arbitrary value, which is particularly useful for specifying the value of
a multibit waveform. The options available when using the Arbitrary Value tool are shown in Figure 14.

( {4 Arbitrary Value @1
Arbitrary Value
Numeric or named value: 111 -
[ OK ] [ Cancel ]
\

4

Figure 14. Options available for for the Arbitrary Value tool.
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As an example, in Figure 15 the count signal is set to three different arbitrary binary values as specified by the

USEr.
r 1
{# Simulation Waveform Editor - D:/simulation_intro/majority3 - majority3 - [majority3.vwil* = | B S
Fie Edit Wiew Simulation Help @ Search attera.com ®
& Ao A Z X EREEZ)E 2 x84 B
Master Time Bar: 0 ps E E] Pointer: 216.81 ns Interval: 216.81 ns Start: 180.0 ns End: 300.0 ns
i N
-
Name TR 0ps 1GD.ID ns 32010 ns 4BU.ID ns G40.ID ns 200.0 ns
Ops 0 ps
& © count B 000 000 4 111 b4 000
4 [ 4 1 [
U 4
100% 00:01:52

Figure 15. The Arbitrary Value tool is used to set values for the count signal.

Random Values /&
This tool assigns random values to the selected waveform(s), with several options as shown in Figure 16.

i Random Values @

Generage random values

(7) Every grid interval

(@) Every half grid interval
(7) At random intervals
(7) At fixed intervals

Interval period: ns

- 4

Figure 16. Various options available for the Random Value tool.

For example, in Figure 17, the signal x; has been given random values.
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W Simulation Waveform Editor - Di/simulation_intro/majority3 - majority3 - [majority3.vwil*

-

=NECE X
File Edit Miew Simulation Help L] Search altera.com e
(M % & & Z)C )E B OHEE 2 )R 2 el 2 (=8
Master Time Bar: 0 ps E E] Pointer: 672.9ns Interval: 672.9 ns Start: 140.0 ns End: 320.0 ns
0ps 160.0 ns. 320.0 ns 430.0 ns. 540.0 ns. 800.0ns
Name Value at ' ' ' '
Ops 0ps
B f BX
B x BO
L BO | |
4 [ 4 1 LA
100% 00:01:52
\

Figure 17. An example of the Random Value tool being used.

Snap to Grid =

This option allows selections made with the Selection Tool to snap to the light grey grid lines running verti-
cally down the waveform display. This option can be toggled on and off by pressing the Snap to Grid button.
It is set to on by default. Figure 18 shows an example of the Selection Tool being used with the Snap to Grid

option turned off.

W Simulation Waveform Editor - Di/simulation_intro/majority3 - majority3 - [majority3.vwil*

-

=NECE X
File Edit Wiew Simulaton Help @ Search altera.com e
e o N EEEWIEEEZE SRS 2 @8
Master Time Bar: 0 ps E E] Pointer: 538.05ns Interval: 538.05 ns Start: 163.93 ns End: 330.5ns
0ps 160.0 ns. 320.0 ns 430.0 ns. 540.0 ns. 800.0ns
Name Value at ' ' ' '
0ps 0 ps
-1 f BX
e o« BO |
L BO | |
4 [ 4 1 LA
100% 00:01:52
\

Figure 18. An example of the Snap to Grid option turned off.

Snap to Transition &

This option allows the Selection Tool to automatically extend both the left and right sides of the selection
rectangle outwards to the first transition encountered by any waveform in the editor. For example, with the
Snap to Transition option turned on, the Selection Tool rectangle shown in Figure 19 would be expanded to
create the selections illustrated in Figure 20. This option can be toggled on and off by pressing the Snap to

Transition button, and is set to off by default.
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W Simulation Waveform Editor - Di/simulation_intro/majority3 - majority3 - [majority3.vwil*

-

SNICE X

File Edit Miew Simulation Help L] Search altera.com e
Ne xS 2T E R EIE P R e A =

Master Time Bar: 0 ps E E] Pointer: 278.94 ns Interval: 278.94 ns Start: End:

I Name Value at Ops 1GD.ID ns 320'.0 ns 4BU.ID ns G40.ID ns 800.0ns * I
Ops 0ps

B f BX

b x B0 |

B = BO | |

s e [ Wl
4 [ 4 1 LA

U

100%

00:01:52

)
Figure 19. Making a selection with the Snap to Transition option enabled.
W Simulation Waveform Editor - Di/simulation_intro/majority3 - majority3 - [majority3.vwil* =HECE X
File Edit Wiew Simulaton Help @ l} Search altera.com e
D &% & & Z )T E R IEE ZE 2w 2 =D
Master Time Bar: 0 ps E E] Pointer:  11.9 ns Interval: 11.9ns Start: 200.0 ns End: 500.0 ns
I Value at 0ps 1GD.ID ns 320'.0 ns 4BU.ID ns G40.ID ns 800.0ns fl
Hame Ops Ops
@l of BX
LI BO |
- % B0 | | |
L a3 BO
4 b 4 1 L S
bl
LI 100% 00:01:52 IJ

Figure 20. The expanded selection resulting from Figure 19.

B Using Multibit Signals

This section describes features of the Simulation Waveform Editor that are useful for dealing with multibit signals.

B.1 Grouping and Ungrouping Signals

Individual signals can be grouped together to create a multibit waveform. This is done by first selecting the desired
waveforms by clicking on their names in the left side of the Waveform Editor with the key Ctrl pressed as indicated
in Figure 21. Then, as shown in the figure, the grouping of signals is done by right-clicking on the selection and

choosing Grouping > Group....
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(_# Simulation Waveform Editor - Di/simulation_intro/majority3 - majority3 - [majority3.vwil* EIEI&J
File Edit Wiew Simulaton Hep @ Search altera.com Q

(e X0 S 2T 0ERIEE R R SR A =
Master Time Bar: 0 ps E E] Pointer:  1.32 ns Interval: 1.32 ns Start: 0ps End: 200.0 ns
0ps 160.0 ns. 320.0 ns 480.0 ns 540.0 ns. 800.0ns
Name Value at ' ' ' '
Ops 0 ps
in E 0 :
_—— _ X Delste Del
o [E- Hnin |
Insert Node or Bus...
L Grouping L Group..
Rewerse Group or Bus Bit Order Ungroup™.
] Radix 4 i1 | -
Create a group from the selecte] g5 Properties... 100% 00:01:52
L = J

Figure 21. An example of grouping signals.

In the options dialogue that opens, illustrated in Figure 22, a name must be assigned to the group, as well as a radix.
In the example shown, the name count has been chosen with a binary radix.

( h Group [ﬂj
Group name: count
|:| Display gray code count as binary count
[ 0K J [ Cancel ]
. -/

Figure 22. Select a name and radix for the group of signals.

The resulting group of signals is shown in Figure 23. The multibit waveform can be expanded in the waveform
editor to display its individual signals.
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W Simulation Waveform Editor - Di/simulation_intro/majority3 - majority3 - [majority3.vwil* =NECE X
Fie Edit Wiew Simulation Hep @ Search attera.com Q

(e 5o 2 ) 8 )EE 2 XA a4 =i

Master Time Bar: 0 ps E E] Pointer: 0 ps Interval: 0O ps Start: 0ps End: 0Ops

-
Name Value at 0ps 1GD.ID ns 320'.0 ns 4BU.ID ns G40.ID ns 200.0 ns
Ops 0ps

|| |@= 2 count B 000 IHRSEIERSETIED SRR SR EE SR IEE SR ED S

m_ x1  BO |

[ X  BO | | |

fm,_ x3  BO

4 SIEN 1 [ &
{ 100% 00:01:52
. =/

Figure 23. An example of expanding a multibit signal.

A multibit signal can be ungrouped by right-clicking on the group of signals and selecting Grouping > Ungroup....

It is also possible to create hierarchical groupings of signals as illustrated in Figure 24. In this example, the two
bit signal called level2 is combined with the signal called x3 to create the three bit signal called levell. It is only

possible to group and ungroup top-level signals.

W Simulation Waveform Editor - Di/simulation_intro/majority3 - majority3 - [majority3.vwil*

=B
File Edit Wiew Simulation Help L Search altera.com 6
e % & M 20 )E B EE 26 2l % FE
Master Time Bar: 0 ps E E] Pointer: 783.95ns Interval: 783.95 ns Start: 0ps End: 0Ops
-
Name Value at Ops 1GD.ID ns 320'.0 ns 4BU.ID ns G40.ID ns &00.0 ns
0ps 0 ps
|
B 4 kven B 00,0 00, 0 W 01,0 MEETED G EED SRR SR
| > level2 B OO [ b4 01 b4 20 b4 11
ig_ x3 BO ,—l—,—
4 [ 4 1 L &y
0% 00:00:00
.

Figure 24. An example of hierarchical groups.

It is also possible to group input and output signals, as shown in Figure 25.
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Master Time Bar: 0 ps E E] Pointer: 642.49ns Interval: 642.49 ns Start: 0ps End: 0Ops
Name Value at Ops 1GD.ID ns 320'.0 ns 4BU.ID ns G40.ID ns 800.0ns *
Ops 0ps

& 4 inout B 000X 000X b4 010X HEECERSE TR SEED SR

[ x1 BO |

8 X2 B0 | | |

i X3 BO L T
S f BX

1 K [0 kv

0% 00:00:00

Figure 25. An example of grouping input and output signals.

B.2 Reverse Group or Bus Bit Order

In Figure 23, the three bit signal count is displayed as the 3-tuple xj x2x3. It is possible to reverse the order in which
the bits are displayed as illustrated in Figure 26. This is done by right-clicking on the name of the multibit signal
and selecting Reverse Group or Bus Bit Order, as seen in the figure.

{h Simulation Waveform Editor - D:/simulation_intro/majority3 - majority3 - [majority3.vwil*

-

=NRaN X

File Edit \iew Simulation Help

M)

(M % & M 2T )E B OEIE 2 )R 8 mE A (=8

Search altera.com

L)

Master Time Bar: 0 ps E E] Pointer: 0 ps Interval: 0Ops Start: Ops End: 200.0 ns
-
Name Value at Ops 1GU.IU ns 320'.0 ns 4BU.IU ns G40.IU ns 800.0 ns
Ops 0ps
nnn 010 D D G T
Delete Del
in Insert Node or Bus...
- x2 |BO |
Grouping 3
in
»- 3 BO Rewverze Group or Bus Bit Order L\\,
Radix 3
4 | 1 b
B Properties...
Change the bit display order of the seleCle@Op-EBvVergroop or oos—————— 0% 00:00:00

Figure 26. Reversing the bit order on a group of signals.

The effects of the bit reversal can be seen in Figure 27. The count waveform is now displayed as the 3-tuple x3x2x;.
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0% 00:00:00

Figure 27. The result of reversing the bit order in Figure 26.
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