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date lesson/lab aula time

01/03/23 intro aula5A, H2bis
14-15 (GF and BT), 
16-17 (NS)

08/03/23 lesson1 aula5A, H2bis 15-18

15/03/23 lab1 sala microscopia F2, C1 15-18
22/03/23 lesson2 aula5A, H2bis 15-18

29/03/23 lab2 sala microscopia F2, C1 15-18
05/04/23 lesson3 aula5A, H2bis 15-18

19/04/23 lesson4 aula5A, H2bis 15-18
26/4/23 lesson5 aula5A, H2bis 15-18

3/5/23 lab3 CIMA center 15-18
10/5/23 lab4 aula5A, H2bis 15-18



Live imaging 

microscopy



• Allows study of dynamic processes in real time in stead of
snap-shot of one timepoint

• Results in movie instead of single image

• Dynamic processes of subcellular compartments, cells, cellular networks, 
organs, entire animals

Examples for dynamic processes of interest
• Cell migration
• Morphological changes
• Physiological parameters (ion concentrations, vesicle dynamics)

LIVE IMAGING



LIVE IMAGING - CHALLENGES

Keeping cells alive
• physiological environment

• Temperature
• Ionic and osmotic environment
• Oxigenation
• pH (ev. CO2 concentration for carbonate buffer)

• Mechanical stress
• Phototoxicity
• Chemical toxicity of dyes



LIVE IMAGING - INCUBATION



LIVE IMAGING - INCUBATION

Incubation chambers can surround the microscope stand
or just the cell dish. Both can maintain cells at the correct
temperature for long periods of time.



CONTRASTING TECHNIQUES

Optical Techniques to Enhance contrast: 
Differential Interference Contrast (DIC) 
Phase Contrast
Darkfield
Polarized Light
Fluorescence

LIVE CELL IMAGING: LABELING CELLS



PHOTOTOXICITY
LIVE CELL IMAGING: LABELING CELLS

The central challenge in live cell imaging – Cells are inherently 
photosensitive!

• Formation of free radicals by fluorophores only exacerbates the problem

• Free radical formation cannot be prevented, only managed by careful tuning of
imaging parameters to reduce light exposure

Live cell imaging requires “gentle imaging” - short exposures of low 
intensity Illumination



FLOURESCENCE LABELLING OF LIVE CELLS

• Detect specific molecules (immunocytochemistry, fluorescent proteins)

• Must keep the specimen transparent

• Targeting live cell (membrane permeability)

• Eventually detect multiple molecules at the same time



MINIMIZING DAMAGE WHILE GETTING GOOG IMAGES

• Resolution vs Speed vs Sensitivity

• Light Gathering Power and Focus Maintenance

• Which immersion media

• Correct coverslip thickness

• 3D Imaging



RESOLUTION-SPEED-SENSITIVITY
– Spatial Resolution

• Depends on application � optical magnification and lens apperture
• Smaller and more pixels = higher resolution

– Sensitivity
• Larger pixels = higher sensitivity
• Higher sensitivity = shorter exposure time
• Shorter exposure time = higher frame rate
• Larger pixels = lower resolution

– Speed
• Less pixels = faster readout
• Faster Readout = higher framerate
• Less pixels = lower resolution
• requires fast readout and high sensitivity

Resolution Speed

Sensitivity



CORRECTION IMMERSION MEDIA

Using water immersion objectives for samples in liquid media captures more 
signal and preserves resolution better than refractive index mismatched oil 
immersion objectives.

oil immersion objective

NA=1.4

water immersion objective

NA=1.2



SIGNAL-TO-NOISE

• Camera Sensitivity -
• Signal needs to be 2-3x brighter than background noise to be 

detected.

• Increasing the exposure time (integration time) or increasing
the illumination intensity produces more signal.



SIGNAL-TO-NOISE

https://scientificimaging.com/knowledge-base/signal-and-noise-quantitative-explanation/



RESOLUTION VS SPEED

512ms 
1x1 binning

117ms 
2x2 binning

28ms 
4x4 binning

Using binning shortens exposure times reducing cell phototoxicity and
fluorophore photobleaching



• Changes of flourescence intesity

• Examples: calcium imaging, vesicle release

• Changes of flouresence localisation

• Examples: Mitochondrial dynamics

CHANGES IN FLOURESCENCE



IMAGING CHANGES IN ION CONCENTRATIONS

A commonly performed live flourescence imaging method is ion

imaging (calcium, chloride, magnesium, etc) using either

fluorescent dyes or proteins especially designed to change their

emission behavior upon binding of the respective ion.



IMAGING CHANGES IN ION CONCENTRATIONS

Using GCaMP

Thalhammer et al, 2022



GCaMP

SYNAPTIC TARGETING OF GCaMPs



SYNAPTOPHYSIN-PHLUORIN (SYPHY) – IMAGING OF VESICLE 
RELEASE



• Changes of flourescence intesity

• Examples: calcium imaging, vesicle release

• Changes of flouresence localisation

• Examples: Mitochondrial dynamics

CHANGES IN FLOURESCENCE



MITOCHONDRIAL PARTICLE DYNAMICS



OTHER LIVE IMAGING TECHNIQUES

• Vesicle fusion/release (TIRF or pH-sensitive GFP)

• FRAP

• FRET

• Photoactivation/Photoconversion



RESOLUTION-SPEED-SENSITIVITY
– Spatial Resolution

• Depends on application � optical magnification and lens apperture
• Smaller and more pixels = higher resolution

– Sensitivity
• Larger pixels = higher sensitivity
• Higher sensitivity = shorter exposure time
• Shorter exposure time = higher frame rate
• Larger pixels = lower resolution

– Speed
• Less pixels = faster readout
• Faster Readout = higher framerate
• Less pixels = lower resolution
• requires fast readout and high sensitivity

Resolution Speed

Sensitivity



Image processing and 

analysis



DIGITAL IMAGES

– 2D structure biult from pixels

– Can be seen as a matrix comprised of m columns and n rows, pixel 
location denoted by indes (i,j)

– for: 0 ≤ I < n and 0 ≤ j < m



RESOLUTION
Microscopy Digital image processing
Rayleigh criterion

The spatial resolution of 
an image is the physical 
size of a pixel in an image

Sparrow criterion
full width at half 
maximum (FWHM)



RAYLEIGH CRITERION

0.8

0.6

0.4

0.2

0

1

4 6 8 10

In
te
ns
ity
[A
.U
.]

-10 -8 -6 -4 -2 0 2
Spatial coordinate [A.U.]

20% intensity
drop

The Rayleigh criterion is the generally accepted, although arbitrary, criterion for the minimum 
resolvable detail – the imaging process is said to be diffraction-limited when the first
diffraction minimum of the image of one source point coincides with the maximum of another.



POINT-SPREAD FUNCTION

• The point spread function (PSF) describes
3D light distribution in an image of a point
source (for a given lens)

• An x-y slice through the center of the
wide-field point spread function reveals a
set of concentric rings: the so-called Airy
disk that is commonly referenced in texts
on classical optical microscopy



POINT-SPREAD FUNCTION - CONFOCAL

PSFexc PSFdet PSFconf● =



RESOLUTION - CONFOCAL



RESOLUTION - CONFOCAL

0

0.2

0.4

0.6

0.8

1

6 8 10

In
te
ns
ity
[A
.U
.]

-10 -8 -6 -4 -2 0 2 4
Spatial coordinate [A.U.]

0

0.2

0.4

0.6

0.8

1

4 6 8 10

In
te
ns
ity
[A
.U
.]

-10 -8 -6 -4 -2 0 2
Spatial coordinate [A.U.]

Rayleigh criterion cannot be used directly to define the improvement of resolution in a 
confocal microscope. The position of the first minimum does not change. The drop in intensity
is much larger, though. In fact, we can move two intensity distributions a little bit closer (1.4
times), and still get the required 20% drop in intensity.



RESOLUTION - CONFOCAL

The full width at half maximum
(FWHM) is a parameter commonly
used to describe the width of a
"bump" on a curve or function. It is
given by the distance between
points on the curve at which the
function reaches half its maximum
value.



SIGNAL-TO-NOISE RATIO AND RESOLUTION
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The influence of Poisson
noise on two intensity
distributions separated
spatially according to the
Rayleigh criterion.



DIGITAL RESOLUTION IN ELECTRONIC PUBLISHING

• Image resolution is measured in pixels per inch (ppi).

• An image with a resolution of 100 ppi, contains 10,000 pixels in a
Square inch (100 pixels wide x 100 pixels high = 10,000).

• The higher the resolution, the more pixels in the image. A 2-by-2-
inch image with a resolution of 100 ppi would have 40000 pixels.

• The same image with a resolution of 300 ppi would have 360,000
Pixels in the same 2-by-2-inch area.



DIGITAL RESOLUTION

128x128 64x64 32x32 16x16



SAMPLING THEORY

• Nyquist Theorem
• sampling frequency (f) required to represent the true identity of

the sample: to capture the periodic components of frequency f in
a signal we need to sample at least 2f times

• Nyquist claimed that the rate was 2f; in reality the rate is 2.3f (~at
least 2 times the highest frequency)



SAMPLING AND NYQUIST



SAMPLING AND NYQUIST



SAMPLING AND NYQUIST
An image that is digitized at a rate of 600 dpi will only be 300 dpi if
enlarged 2X and printed

Ø practical sampling guideline for printed images is that the
final image should have at least the resolution of the printing
device

For light and electron micrographs of biological tissue, prints with a
final resolution of 600 dpi will preserve most detail. However, fine
granular structures such as autoradiography silver grains or
colloidal gold particles used in immunolabeling will not be as sharp
as those in a traditional photograph

Ø the final print resolution may need to be 1200 dpi or higher.



BIT RESOLUTION OR PIXEL DEPTH

• This is a measurement of the number of bits of information per pixel.

• The pixel depth will determine how much color or gray scale
Information is available for each pixel.

• Greater pixel depth means more available colors and more accurate color
representation.

• Pixels in binary images have a depth of 1 (on or off), and are black and white
images

• A pixel with a bit depth of 8 has 28, or 256, possible values; and a pixel with a bit
depth of 24 has 224, or 16 million possible values (red=8, green=8, blue=8).

• Common values for pixel depth range from 1 to 24 bits per pixel.



QUANTIZATION

• A set of n quantization levels comprises the integers:
0, 1, 2, …, n-1
• 0 and n-1 are usually black and white respectively, with

intermediate levels rendered in various shades of gray.
• Quantization levels are commonly referred to as gray levels.
• n is usually an integral power of two: n=2b, where b is the

number of bits used for quantization.
• If b=1 then the image is binary



QUANTIZATION

256 16 4 2





Deriving quantitative information from images of biological samples





Algorithms must be reliable. Visualization helps gaining trust in methods



QUANTITATIVE MICROSCOPY IS SUPPOSED TO BE:



IMAGE ANALYSIS IS PART OF THE EXPERIMENT

• Think about how to analyze your images before starting the
experiment.

• Consider adapting your experiment so that quantitative image 
analysis can be performed easily.

• Think about controls, counter-proves, an easy to falsify null-
hypothesis

• Do simple experiments.
• How can you exclude yourself from the experiment?
• Think of blinding yourself or fully automate analysis.
• One experiment usually answers just one or less questions.



COMMON QUESTIONS IN QUANTITATIVE MICROSCOPY

1. Numbers (particles, spots, nuclei. etc)

2. Morphometry (length, Feret diameters, roundness, etc)

3. Densitometry (intensity base analysis on fluorophores)

4. Colocalization

5. Live imaging & tracking



FIJI – freely available image analysis program





• The same image can be displayed in different ways by adjusting the
contrast settings or the LUT.

• Nevertheless, despite the different appearance, the values of the pixels
are the same in all three images.















• Images mostly needed to be transformed into quantifiable data

• ImageJ is useful for getting information from images, including pixel
intensity.

• There are a number of different ways to get intensity information from
images using the base package of ImageJ (no plugins required).

Basic Intensity Quantification with ImageJ



IMAGE FILTERING



FILTERS



EFFECTS HARMING IMAGE QUALITY



NOISE



IMAGE CORRECTION/NOISE REMOVAL



IMAGE CORRECTION/NOISE REMOVAL



LINEAR FILTERS



LINEAR FILTERS



LINEAR FILTERS



LINEAR FILTERS



BACKGROUND REMOVAL



BACKGROUND REMOVAL



BACKGROUND REMOVAL



BACKGROUND REMOVAL



MATHEMATICAL OPERATIONS ON IMAGES



MATHEMATICAL OPERATIONS ON IMAGES



MATHEMATICAL OPERATIONS ON IMAGES



DIFFERENCE OF GAUSSIAN (DoG)



DIFFERENCE OF GAUSSIAN (DoG)



NON-LINEAR FILTERS



NON-LINEAR FILTERS



LAPLACE FILTERS



LAPLACIAN OF GAUSSIAN (LoG)



• Images mostly needed to be transformed into quantifiable data

• ImageJ is useful for getting information from images, including pixel
intensity.

• There are a number of different ways to get intensity information from
images using the base package of ImageJ (no plugins required).

Basic Intensity Quantification with ImageJ



Quantify Gray Levels Across
an Entire Image or Single
Object/Region



If you want to limit your
measured area to just your object
you draw a region of interest
(ROI) around your object with
one of the drawing tools (in the
toolbar) and then

Analyze

Measure









Alternatively, you can go to
Analyze > Set Measurements

and check off the box next to
“Limit to Threshold.”
Then use
Image > Adjust >Threshold

to highlight the area you want to
analyze, and then
>Analyze



• You can use Analyze > Plot Profile to create a plot of intensity
values across features in your image.

• In the example below, the plot gives the intensity values along the
line drawn across three cell processes.



To Quantify Gray Levels for Each Object in
Images with Multiple Objects

convert to grayscale create a binary image, Process > Binary >
Watershed



Analyze > Analyze Particles

>



An simple image analysis workflow for detecting and measuring small spots, 
applied to the red channel of the sample image HeLa Cells.









https://youtu.be/GHvndpGQKe4

ImageJ How to Measure Mean Fluorescence Intensity
Over Timelapse Image Stack

https://youtu.be/nIRhHb04u_k

Short introduction to histogram processing


