


Tutorial FPGA n.1

Realizzazione di un semplice circuito logico su DE1

Descrizione: Sirealizzi un semplice circuito logico su DE1 [1-2] con ingressi pilotati dagli switches ed
uscita su LED.

Scopo: familiarizzare col tool di sviluppo, con la scheda di sviluppo DE1, apprendimento dei passi
fondamentali da seguire per portare a termine un progetto completo.

Apprendimento previsto:
e Primi rudimenti per navigare all’interno del tool quartus
e Compilazione di un progetto descritto in forma schematica
e Compilazione di un progetto descritto tramite HDL (Verilog o VHDL)
e Imposizione di alcuni vincoli realizzativi (Pin position)
e Simulazione e debugging del circuito (a diversi livelli di astrazione)
e Visualizzazione e verifica delle caratteristiche temporali (ritardi di propagazione)
e Visualizzazione del layout del circuito
e Download e running del circuito su scheda DE1

Procedimento

1. Fase introduttiva
Si apra il tool quartus [3] tramite icona sul desktop oppure dall’elenco dei programmi istallati
Si crei un nuovo progetto o ciccando sull’apposito tasto oppure tramite
File > New Project Wizard
Si definisca

- il direttorio nel quale salvare i files di sistema (non si usino spazi — per cui evitare ad esempio
direttori quali “My Documents”)

- il nome del progetto, e definire (provvisoriamente)

- il nome del blocco piu alto in graduatoria del progetto (top level devign entity) — tipicamente
qguesto prende il nome stesso del progetto e comunque puo essere modificato in seguito.

(Next)

Ove si volessero importate files gia scritti si puo agire su questa pagina (in questo caso si puo passare alla

pagina successiva

(Next)

Si definisca il dispositivo (FPGA) per il quale sviluppare I'intero progetto. Ovviamente il progetto stesso, le
risorse disponibili e la struttura stessa dipendono dal dispositivo utilizzato — esistono centinaia di FPGA
diverse per famiglia, caratteristiche, prestazioni, piedinatura ecc. E FONDAMENTALE scegliere 'FPGA



corretta [4-5] . Nel nostro caso sulla DE1 € montata una EP2C20F484C7N della famiglia Cyclone II
pertanto sceglieremo la:

Altera — Ciclone II - EP2C20F484C7

(Si noti che il suffisso N indica solo che il dispositivo rispetta la normativa comunitaria 2002/95/CE la quale
impone alcune restrizioni sull'uso di determinate sostanze pericolose nella costruzione di apparecchiature
elettroniche).

In questa fase potrebbe essere comodo I'impiego di opportuni “filtri” per isolare velocemente il dispositivo
di nostro interesse come ad esempio fissare il Pin Count a 484 e vincolare il fatto che la sigla del dispositivo
debba contenere la stringa “20”

a New Project Wizard

Family & Device Settings [page 3 of 5]

Select the family and device you want to target for compilation.
You can install additional device support with the Install Devices command on the Tools menu.

Device family Show in'Available devices' list
Family: |Cydone II +|  Package:  |Any -
Devices: | Al Pincount: 484 -

Target device Speed grade: |Any -

() Auto device selected by the Fitter Neme filter: |20
(®) Specific device selected in *Available devices' list [] Show advanced devices Har
Available devices:

Hame Core Voltage LEs User I/0s Memory Bits Embedded multiplier 9-bit elements PLL  alCk
EP2C20AF484AT 1.2V 18752 315 239615 52 4 6
EP2C20AF43418 1.2V 18752 315 239616 52 4 16
EP2C20F484C6 1.2V 18752 315 239615 52 4 6
EP2C20F484C7 1.2V 18752 315 239616 52 4 16
EP2C20F434C8 1.2V 18752 315 239615 52 4 6
EP2C20F48418 1.2 18752 315 239616 52 4 16

Companion device (&

< Back Finish Cancel Help

La tabella presente in questa pagina consente di paragonare le prestazioni dei vari dispositivi (celle logiche,
memoria a disposizione, moltiplicatori integrati, PLL, risorse di I/O, linee di clock dedicato) ... questo
potrebbe essere utile laddove non sia stato definito ancora il dispositivo sul quale realizzare il sistema.

(Next)

In questa pagina si possono fissare programmi di terze parti da usare per la sintesi, la simulazione e I’analisi
temporale. In questo caso si definisca come tool per la simulazione ModelSim — Altera e come linguaggio da
adottare Verilog HDL — disattivare “Run Gate-level simulation automatically after compilation” .

(Next)

Una pagina riassuntiva elenca le scelte fatte, verificarne la coerenza

(Finish)



2. Definizione dell’ architettura sistema (Tramite schematico) [5-6]

File > New
Block Diagram / Schematic file (OK)

Nella nuova pagina grafica che compare, tracciare lo schematico del sistema da realizzare simile a quanto
riportato in figura.

Si impieghino i tasti L e 1 per accedere alla libreria delle porte logiche e per creare i vari collegamenti.

In particolare si suggerisce:

- di prendere visione delle diverse porte logiche e strutture hardware disponibili suddivise tra
Megafunctions: funzioni complesse ad alto livello di astrazione (verranno utilizzate in seguito)
Others: funzioni particolari legate ad una particolare famiglia di FPGA
Primitives: funzioni generiche

- di analizzare le varie opzioni grafiche disponibili (ad esempio quella di poter modificare la posizione dei
gate mantenendo inalterati i collegamenti o viceversa spostare i gate senza i collegamenti)

- dare un nome mnemonico convenuto alle varie porte logiche e soprattutto ai pin di ingresso ed uscita.
NOTA BENE: utilizzare dei nomi abbastanza specifici ed evitare possibili parole “riservate” quali ad

n o«

esempio: “in”, “out”, “inout”, “and”, “inv”, ...., cosi come parole magari pit improbabili come “for”,
”n u

“while”, “goto” ecc. ecc.
Si salvi lo schematico e se ne verifichi la correttezza del circuito attraverso un processo di analisi.

Processing > Start > Analisys and Elaboration

Si noti che esistono eventualmente delle scorciatoie nella finestra dedicata ai Tasks.
Si correggano eventuali errori (un doppio click sul messaggio d’errore aiuta ad evidenziare la parte
interessata)



3. Simulazione funzionale [7]

Creare un file di stimoli :

File > New
University Program VWE (OK)

(si apre la finestra ove definire gli stimuli)
Definire quali segnali debbano essere monitorati:

Edit > Insert > Insert Node or Bus
Clk on Node Finder

Filters: Pin:all

Cilk on List

Cilk on >>

OK

OK

Definire la scala dei tempi

Edit > Set End Time

Configurare a 200 ns

OK

Definire lo la risoluzione adottata dalla scala temporale

Edit > Grid Size

Configurarea 1 ns

OK

Utilizzando il tool grafico a disposizione disegnare le f.d.o. degli stimoli desiderati

o
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Salvare il file di stimoli

File > Save
Dare un nome opportuno o lasciare il nome di default (di solito si usa per convenzione lo stesso nome del
blocco da simulare seguito dal suffisso “_tb” onde ricordare a quale blocco si applica detto file di stimoli)

OK
Verificare nelle opzioni di utilizzare il simulatore integrato all’'interno di Quartus.

Simulation > Option

E scegliere Il Quartus Il Simulator

Simulator:

() Modelsim (Recommended) (@ Quartus II Simulator

carcel

Si tenga presente che questo & un simulatore molto semplice da usarsi solamente in ambito didattico. Per

simulazioni piu approfondite si consiglia di impiegare ModelSim. Per il cui utilizzo si rimanda al tutorial
specifico.

Far quindi partire la simulazione

Simulation > Run Functional Simulation

o
. '3 .
(esiste eventualmente lo shortcut ™ sul pannello comandi)

In questo modo si attiva una simulazione funzionale a livello RTL. Essa rispecchia il funzionamento ad alto
livello di astrazione della funzione sviluppata ed essa non possiede ancora le informazioni su eventuali

tempi di propagazione e di ritardo. Verificare le f.d.o in uscita e la loro congruenza con quanto ci si
aspettava.
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Ove si provasse ora a lanciare la simulazione temporale

Simulation > Run Timing Simulation ™™



Si otterrebbe probabilmente un messaggio di errore

Running quartus eda timing netlist =l
>> quartus eda --functional=off —-timescale=lps --simulation --tool=

modelsim oem --format=verilog tutoriall -c tutoriall
PID = 15196

Running Quartus II 64-Bit EDA Netlist Writer

Version 13.0.1 Build 232 06/12/2013 Service Pack 1 SJ Web Edition

Processing started: Wed Jan 01 09:44:22 2014
Command: guartus eda -—-functional=off —-timescale=1ps --simulation=o
n —-tool=modelsim oem --format=verilog tutoriall -c tutoriall
Selected device EP2C20F484C7 for design "tutoriall"
Run the Fitter, followed by the TimeQuest Timing Analyzer, before ru
nning the EDA Netlist Writer
Quartus II 64-Bit EDA Netlist Writer was unsuccessful. 1 error, 0 wa
rnings

Peak virtual memory: 382 megabytes

Processing ended: Wed Jan 01 09:44:22 2014

Elapsed time: 00:00:00

Total CPU time (on all processors): 00:00:00

]
Failed to generate simulation netlist

Questa e infatti una simulazione a piu basso livello che puod essere eseguita solo dopo che il circuito é stato
completamente definito in tutti i suoi collegamenti interni all’FPGA. Essa richiede pertanto di eseguire
preventivamente un processo completo di sintesi e mapping che pertanto deve venir realizzato (vedi
seguito) prima che tale simulazione possa venir attivata.

4. Definizione dei vincoli [8-9]

Al momento ci si limitera a fissare dei semplici vincoli di posizionamento per i pin di ingresso e di uscita,
onde fare in modo che gli ingressi siano associati rispettivamente agli switches 0 e 1 e che l'uscita sia
collegata al led rosso numero 0.

Dal manuale utente della DE1 [1-2] si evince che SW[0] e collegato al piedino PIN_L22, mentre SW[1] &
collegato al piedino PIN_L21. Inoltre il LEDRO e collegato al PIN_R20. Si tratta pertanto di associare queste
posizioni ai piedini di ingresso e di uscita del nostro circuito (provare eventualmente altre associazioni, ma
sempre col vincolo che ovviamente gli swithes possono essere impiegati esclusivamente come ingressi.
Sebbene sia la scheda che I'FPGA hanno delle protezioni, da un punto di vista generale, assegnare un valore
logico ad un segnale che poi viene esternamente forzato ad un valore logico diverso crea un conflitto che
potrebbe danneggiare il dispositivo stesso.

Assignments > Pin Planner (ctrl-shift-N)

Editare opportunamente la tabella come da figura:
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4 [ Change View

MNamed: * Y] Edit:| 3§ ||« |Fi|her:| Pins: all
Mode Name Direction Location 1j0 Bank VREF Group 1/O Standard Reserved Current Strength Differential Pair
L Input PIN_L22 B5_N1 3.3V LV... default) 24mA (default)
In_ x2 Input PIN_L21 B5_N1 3.3V LV... default) 24mA (default)
out Output PIN_R20 B6_NO 3.3V LV...default) 24mA (default)
< <new node > ]

0% 00:00:00

Chiudere la finestra

Notal: analogo risultato & ottenibile anche utilizzando il tool “assignment editor” che pud essere
impiegato anche per assegnare vincoli di altra natura..

Assignments > Assignments Editor (ctrl-Shift-A)

Nota2: Un altro modo piu comodo per I'assegnazione dei vincoli di piedinatura (utile soprattutto quando il
numero di piedini da assegnare & piuttosto elevato e quello di realizzare con un text editor un file testuale
con estensione .csv (comma spaced values) ove i singoli valori sono separati da una virgola;

per esempio

To, Location
SW[0],PIN L22
SW[1],PIN L21
LEDR[O], PIN_RZO

Ed importarlo nel progetto mediante

Assignments > Import Assignments

Se si riapre lo schematico, verificando che sia attiva I'opzione

View > Show Location Assignments

Si ha una rappresentazione grafica direttamente su schematico della locazione dei vari PINS



[P 21 ]

5. Compilazione completa del progetto

A questo punto si pud procedere con la compilazione completa del progetto. Questa prevede diversi passi
“Analisi”, “Sintesi”, Place & Route”, “ Generate programming file”, “Time Quest Timing analysis”, ecc. ecc.
che pero vengono automaticamente svolti in sequenza:

Processing > Start Compilation (ctrl-L).

6. Simulazione temporale:

A questo punto il circuito € completamente realizzato e perfettamente definito in tutte le sue funzionalita
ed in tutti i suoi ritardi strutturali, si puo pertanto effettuare una simulazione a piu basso livello di
astrazione che tenga conto anche di queste peculiarita.

Siriapra il file (o la scheda) dove sono stati definiti gli stimoli, ovvero le forme d’onda e si attivi:
[

Simulation > Run Timing Simulation ™

Verificare le f.d.o in uscita, la loro congruenza e soprattutto si notino i ritardi rispetto gli stimoli di ingresso.
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7. Visualizzazione del layout del circuito [10]:

Tools > Chip Planners

Utilizzare lo zoom per evidenziare piccole parti del circuito e tramite doppio click sulla singola cella

evidenziarne la configurazione specifica.

Evidenziare in particolare i LE coinvolti dal progetto, i loro collegamenti, le porte di I/O interessate, i
collegamenti e le loro configurazioni interne

i e W chps Kl

8. Visualizzazione ed analisi dei vari report di processo:

Molto probabilmente la finestra contente tutti i reports di processo dovrebbe essere gia aperta, altrimenti
si puo richiamare con

Processing > Compilation Reports (ctrl-R)

| vari reports sono organizzati per sezioni cosi come lo sono le varie fasi del processo di compilazione.
Analizzarli nel dettaglio, in particolare soffermarsi sulle risorse impiegate all’interno dell’FPGA

Analysis & Settings > Resources Usage Summary

sulla congruenza della piedinatura

Fitter > Pin-out File



e sui ritardi previsti secondo diversi modelli (ottimistico e pessimistico)

Time Quest Timing Analysis > Slow Model > Datasheet Report > ..
. > Propagation Delay

Time Quest Timing Analysis > Fast Model > Datasheet Report > ..
. > Propagation Delay

9. Analisi dettagliata dei ritardi

Per effettuare un’analisi maggiormente dettagliata dei ritardi di propagazione dei vari percorsi del segnale
si puo utilizzare uno strumento dedicato a tale scopo, denominato “Time Quest Timing Analyzer” [11-12-
13]

Tools > Time Quest Timing Analyzer

Nella nuova finestra si creino le informazioni relative alle temporizzazioni

Netlist > Create Timing Netlist

E si scelga la modalita di analisi (Post-fit) ed il modello da adottare (Slow).

A questo punto bisognerebbe fissare il clock del sistema, la sua frequenza di lavoro ed i vincoli entro i quali
il sistema dovrebbe sottostare, ma data la semplicita del progetto in questione si pud passare alla fase
successiva:

Netlist > Update Timing Netlist

Ora si visualizzi il report di interesse

Reports > Custom Reports > Reports Path

La finestra che si apre ha funzione di filtro onde visualizzare, all’interno di un progetto complesso solo i
paths di nostro interesse, ma nel caso in esame si possono visualizzare tutti i paths essendo essi solamente
due. Si porti pertanto la variabile “Reports Number of Paths” ad un valore superiore a 2 e si clicchi su
“Report Paths”
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o oss7 o y

2 5387  x2 ¥
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Nella finestra che cosi si apre si avra un report dettagliato in tutti i passaggi dei due paths che compongono
il nostro circuito dall'ingresso del segnale fino all’uscita di quest’ultimo. Inoltre cliccando col tasto destro
sul path di nostro interesse e scegliendo “locate path” si puo individuare il path in oggetto in alcune delle
possibili visualizzazioni del circuito.

Ad esempio nel Chip Planner, sfruttando il comando

View > Show Delays

Si possono visualizzare il loco i ritardi dei vari step del percorso.

10. Test su Scheda

Giunti a questo punto non rimane che scaricare il bitstream (che contiene tutte le informazioni sulla
configurazione dell’FPGA) sulla FPGA medesima

- Verificare che il microswitch SW12 sia nella posizione RUN
- Collegare il cavo di download USB
- Accendere la scheda

Dopo un istante la scheda si configurera in base al file di configurazione residente nella flash [1] che di
default prevede la realizzazione di pattern grafici sui led, la creazione di un disegno sulla porta VGA e la
generazione di un segnale sinusoidale all’uscita della porta audio (disattivabile tramite lo switch SW[9].

Tool > Programmer



Eventualmente - Click on “Hardware setup” e scegliere USB-Blaster
Eventualmente - evidenziare con un click il file “.sof” da
utilizzare
Click on Start
Verificare il corretto funzionamento del sistema

11. Descrizione mediante HDL [11]

Un altro metodo molto piu utilizzato per descrivere sistemi digitali € quello di utilizzare linguaggi di
descrizione hardware (HDL). Fra questi i pilt comuni sono Verilog HDL [14-15-16] e VHDL [17].

Per descrivere un sistema in HDL:

File > New
Verilog HDL File -oppure- VHDL File

A questo punto si apre una finestra di testo per descrivere il sistema in oggetto. Molto utile puo essere in
qguesto caso I'utilizzo dei “template”

Edit > Insert Template

Una descrizione del progetto piu sopra riportato utilizzando il Verilog HDL potrebbe essere la seguente:
module tutoriall (x1,x2,vy);

input x1,x2;
output y;
wire notl,not2,tl,t2;

assign notl = ! x1;
assign not2 = ! x2;
assign tl = x1 & not2;
assign t2 = x2 & notl;
assign y = tl | t2;

endmodule

|ll

Salvare il file con un nome appropriato (adottare lo stesso nome del “module”)

A questo punto nel progetto vi sono due descrizioni dello stesso oggetto, si deve evidenziare a quale si
vuole fare riferimento per procedere. Per selezionare la descrizione adatta

e Andare nella finestra Project navigator
Ove questa non fosse gia aperta aprirla tramite

View > Utility Windows > project Navigator (Alt-0)

e Selezionare il tab “Files”
e Right-click sul file appena salvato
e Selezionare “Set as Top Level Entity”



Eventualmente per evitare confusione si puo rimuovere la descrizione tramite schematico(utile
specialmente se entrambe le descrizioni hanno il medesimo nome).

Click destro sul file e scegliere “Remove File from the Project”

Se si sono mantenuti | medesimi nomi per le porte di ingresso e di uscita si possono utilizzare le medesime
procedure descritte sopra (senza dover re-impostare il file di stimoli ed il file di vincoli) per:

e Effettuare una simulazione funzionale
e Compilare il nuovo sistema

e Effettuare una simulazione temporale
e Visualizzare il floorplanning

e Visualizzare i vincoli

e Effettuare il downlload su scheda

Altrimenti bisogna creare nuovi files che rispecchino i nuovi nomi assunti dalle porte.
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