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1 Introduction and problem definition 1

1 Introduction and problem definition
This tutorial document shows how to perform a full CFD analysis of a vehicle aerodynamics
problem using ANSYS Workbench 2020 platform (hereafter "WB").

The geometry will be defined using ANSYS SpaceClaim 2020 (hereafter "SpaceClaim"),
the mesh will be generated using ANSYS Meshing 2020 (hereafter "ANSYS Meshing")
and the problem will be solved using ANSYS Fluent 2020 (hereafter "Fluent") with RANS
(Reynolds-Averaged Navier-Stokes) formulation: a turbulence model will be employed to find
a steady-state solution.

For the sake of simplicity, the specific vehicle for this study case is the Ahmed’s body [1],
whose geometry is reported in Figure 1, in the case of a rear slant angle of 25◦.

Beside its basic geometry, the physics of the problem is not trivial:

“Most of the drag of the body is due to pressure drag, which is generated at the
rear end. The structure of the wake is very complex, with a separation zone and
counter-rotating vortices coming off the slant side edges, whose strength is mainly
determined by the base slant angle.” [3] (See Figure 2).

Once the characteristics of the problem have been defined as in Table 1, where air at T = 20◦

C is the working fluid, our main goal is to compare the computed drag coefficient CD to
experimental data:

CD =
2Fx

ρu2∞Ax

(1)

where Fx is the computed x-component of the force acting on the body (drag force) and
Ax is the projected body area along the x-axis.

Since we’ll use a RANS (time-averaged) approach, we can take advantage of the symmetry
of the problem around the x-y plane (see Figure 1) for both geometry and boundary conditions
to simulate half the space around the Ahmed’s body.

Figure 1: Ahmed’s body with a rear vehicle slant angle of 25◦ (dimensions in mm).
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2 2 Workbench project

Figure 2: Rear separation zone (from [1]).

Characteristics of the problem.

L = 1044 mm
W = 389 mm
H = 288 mm
Ax = 0.057516 m2

u∞ = 40 m/s
T = 20◦ C
µ = 1.789 × 10−5 kg/(m·s)
ρ = 1.225 kg/m3

Re = ρ u∞ L
µ = 2.86×106

Table 1: Problem characteristics.

2 Workbench project
− Start WB and drag&drop a Fluid Flow (Fluent) component into the main window as in
Figure 3; rename it Ahmed_body and save this new project: File→ Save as...

Figure 3: WB project (Fluid Flow with Fluent).
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2.1 Geometry definition with SpaceClaim
− Right click on Geometry and click on New SpaceClaim Geometry... to define a new geom-
etry with SpaceClaim (Figure 3).

Figure 4: SpaceClaim.

− Click on Sketch mode icon and move the mouse in the main window to position the
sketch on the x − y plane (or click on the z axis), then click on Plan view icon to
have an orthogonal plan view (Figure 4).
− Using Line, define the simplified 2D profile of the Ahmed’s body reported in Figure 5:

Figure 5: Ahmed’s body starting profile.
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4 2.1 Geometry definition with SpaceClaim

− Click on View icon and select the Trimetric view (Figure 6):

Figure 6: Trimetric view.

− Now we can extrude the profile using the Pull command: click on the profile and insert
194,5mm by keyboard to pull the profile along the +z direction (Figure 7):

Figure 7: Pull command to extrude the profile.
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− Use middle mouse button to rotate the view, mouse wheel to zoom the view, Ctrl + middle
mouse button to move the view.
− To create the double roundings on the vehicle front, select Pull command and click on one
of the front edges, then click on Round icon (Figure 8):

Figure 8: Roundings.

− Specify 100mm by keyboard as rounding radius (Figure 9):

Figure 9: Roundings.

− Repeat this rounding operation for top and bottom edges.
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− Select the Sketch mode icon and select the bottom plane of Ahmed’s body (Figure 10), then
click Plan View.

Figure 10: Sketch plane definition.

− Use Construction line and Offset Curve to draw the construction geometry of Figure 11 that
will be required to define the supporting feet of Ahmed’s body:

Figure 11: Bottom construction geometry.
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− Using Circle, draw the base of cylindrical feet of Ahmed’s body, specifying 30mm by
keyboard as diameter (Figure 12):

Figure 12: Supporting feet geometry.

− Use Pull to extrude both circles with an extruding length of 50mm, defined by keyboard
(Figure 13):

Figure 13: Supporting feet.

Now the geometry of the Ahmed’s body is completed, but we need to define an external
enclosure to simulate the external aerodynamics around the body. This enclosure starts 2L
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before the body and extends 5L behind it; its height is 1.4m and its width is 2.5W (these di-
mensions are recommended for the 10th joint ERCOFTAC Workshop on Refined Turbulence
Modelling).
− Click on Prepare tab and then click on Enclosure icon; select Box as Enclosure type and
untick Symmetric dimensions (Figure 14):

Figure 14: Enclosure options.

− Select the body and insert the dimensions reported in Figure 15, then click on icon:

Figure 15: Enclosure dimensions.
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− In the Structure tab, right click on Solid (the Ahmed’s body)→ Suppress for Physics since
we don’t need to mesh it nor to perform calculations inside it (as it would in the case of a
two-way fluid-structure coupling) (Figure 16):

Figure 16: Ahmed’s body volume is not required for our CFD analysis.

Since we want to increase the mesh resolution around the body, we need to define a Body
of influence: click on Sketch icon under Design tab and select the symmetry plane of the
Ahmed’s body (Figure 17):

Figure 17: Plane selection for Body of influence definition.
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− Click on Plan View and define the rectangular geometry of Figure 18 (the x length of the
body is 1044mm, the width of the rectangle is 2544mm):

Figure 18: Body of influence definition.

− In the Structure tab, untick Solid and Enclosure (Figure 19):

Figure 19: Body of influence definition.
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− Click on Pull to extrude the rectangular profile in the +z direction for 400mm (Figure 20):

Figure 20: Body of influence.

− Rename the new solid as ’Size_box’ (Figure 21):

Figure 21: Ahmed’s body enclosure.

− File→ Save Project and close SpaceClaim.
Now that every geometric entity has been defined, we can start meshing the enclosure using
ANSYS Meshing.
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2.2 Meshing the enclosure with ANSYS Meshing
In WB, right click on Mesh→ Edit to mesh the enclosure in ANSYS Meshing (Figure 22):

Figure 22: Starting a new Meshing session from WB.

− Under Outline tab → Project → Model → Geometry right click on FFF\Size_box and
select Hide Body (Figure 23):

Figure 23: Hiding the body of influence.
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− Click the Face icon and select the inflow face (left click), then right click on it→ Create
Named Selection and specify the name Inflow (Figure 24):

Figure 24: Named selection.

− Repeat this operation for all the faces of the enclosure (Top, Ground, Side, Symmetry,
Outflow, Ahmed_surface). For the surface of the Ahmed’s body: click on the z axis for a side
view, click on Select Mode→ Box Select to easily select all its patches (Figure 25):

Figure 25: Ahmed’s surface selection.
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14 2.2 Meshing the enclosure with ANSYS Meshing

− Under Outline tab→ Project→ Model→ Mesh, in the Details of "Mesh" tab, specify all
the marked properties as in Figure 26:

Figure 26: Mesh Sizing and Inflation properties.

− Since we want an extruded mesh with prisms in the boundary layers, we must define their
locations; under Outline tab→ Project→ Model→ Named Selections, click on Ground and
set Include under Program Controlled Inflation in the Details of "Ground" tab (Figure 27):

Figure 27: Inflation locations.

− Repeat the same operations for the Ahmed_surface Named Selection.
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− Outline→ Project→ Model, right click on Mesh→ Insert→ Sizing (Figure 28):

Figure 28: Mesh sizings.

−Under Outline tab→ Project→Model→Geometry, right click on FFF\Size_box→ Show
Body; click the Single Select icon and Body icon ;

− Repeat the insertion of a new sizing: in Details of "Sizing" - Sizing tab, for Scoping Method
select Geometry Selection, for Geometry select the whole enclosure, for Type select Body
of Influence, for Bodies of Influence select the size box and for Element Size insert 0,030m
(Figure 29).

Figure 29: Mesh sizings.
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16 2.2 Meshing the enclosure with ANSYS Meshing

− Right click on Mesh→ Generate Mesh to create the mesh (Figure 30):

Figure 30: Mesh detail around the body.

− Outline→ Project→Model→ Geometry, click on Mesh to display the mesh; click on the
top Mesh tab → Insert → Section Plane to insert a section plane for exploring the volume
mesh (Figure 31). Click on Show Whole Elements icon to display whole mesh elements
and not their projection on the section plane:

Figure 31: Mesh prism layers around the body surface and the ground.

The meshing phase is now complete: the mesh is composed by 380k tetrahedrons (Tet4, 4
nodes) for the volume mesh and 100k triangular prisms (Wed6, 6 nodes) in the inflation layers
near the walls.
− File→ Save Project... to save the mesh into the WB Project and close ANSYS Meshing.
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2.3 Setup the problem in Fluent
In WB, right click on Setup→ Edit to launch Fluent (Figure 32):

Figure 32: Starting Fluent from WB.

− In the Fluent Laucher window, untick Double Precision Option (Figure 33):

Figure 33: Fluent settings.

R. Zamolo, E. Nobile - April 2020
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− Under the Tree tab→ Setup→ General, click on Check and Report Quality to check the
mesh quality and set the marked settings as in Figure 34:

Figure 34: Fluent general Settings.

− Under Setup→ Models double click on Viscous - SST k-omega to specify a Realizable k-ε
turbulence model with Non-Equilibrium Wall Functions as in Figure 35:

Figure 35: Turbulence model.
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− Under Setup→ Materials→ Fluid, click on air to check the correct values of Density and
(Dynamic) Viscosity as in Figure 36:

Figure 36: Air properties.

− Setup→ Cell Zone Conditions, double click on enclosure_enclosure to check our enclosure
is filled with Fluid air as in Figure 37:

Figure 37: Cell zone conditions.
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20 2.3 Setup the problem in Fluent

− Under Setup→ Boundary Conditions, right click on the chosen Named Selection→ Type
to set the correct boundary condition (Figure 38): side, symmetry and top boundary condi-
tions must be set to symmetry type (no shear stress), ahmed_surface and ground boundary
conditions must be set to wall;

Figure 38: Boundary condition types.

− For inflow, set it as velocity-inlet type with the marked settings of Figure 39:

Figure 39: Inflow conditions.
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− For outflow, set it as pressure-outlet type with the marked settings of Figure 40:

Figure 40: Outflow conditions.

− Under Setup→ Reference Values, specify inflow under Compute from and Ax = 0.057516
m2 as Area (Figure 41):

Figure 41: Reference values.
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22 2.3 Setup the problem in Fluent

− Under Solution→ Methods select the Coupled method for the Pressure-Velocity coupling
and First Order Upwind (for now) for Momentum, Turbulent Kinetic Energy and Turbulent
Dissipation Rate (Figure 42):

Figure 42: Solution settings.

− Under Solution→ Controls specify 0.3 for both Momentum and Pressure Pseudo Transient
Explicit Relaxation Factors (Figure 43):

Figure 43: Solution controls.
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− Under Solution → double click on Report Definitions to define new quantities to be re-
ported; select New→ Force Report→ Drag to define a drag report (Figure 44):

Figure 44: Drag report definition.

− Under Drag Report Definition specify the settings of Figure 45 to define a drag coefficient
report:

Figure 45: Drag report definition.

− Repeat the previous procedure to define a Lift Report Definition if needed.
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− Under Solution→ Monitor → Residual tick Show Advanced Options and set the Conver-
gence Criterion to none since we’ll define a fixed number of iterations (Figure 46):

Figure 46: Residual monitors settings.

− Under Solution→ Initialization select Hybrid Initialization and click Initialize (Figure 47):

Figure 47: Solution initialization.
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− Under Solution → Run Calculation set 50 as Number of Iterations and click Calculate
(Figure 48); anyway, we can stop the calculation before the 50 iterations if we believe the
solution to be acceptable (checking residuals or report plots, for example).

Figure 48: Residual history plot.

− When the solution "converged" (we are employing first order upwind schemes), we can
go back to Solution → methods to select Second Order Upwind for Momentum, Turbulent
Kinetic Energy and Turbulent Dissipation Rate (Figure 49) to improve the calculations (less
numerical viscosity dissipation); run the simulation for 200 additional iterations for example.

Figure 49: Switching to Second Order Upwind.
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The history plot of drag coefficient CD is reported in Figure 50; we can see that with First
Order Upwind scheme (=till 50 iterations) for all the transported quantities (velocities and tur-
bulent quantities), CD "converged" to 0.45, while the Second Order Upwind scheme (=above
200 iterations) decreased CD to 0.334. This is in perfect agreement with the upwind schemes:
first order scheme is more diffusive than second order and simulates a higher viscosity flow
with higher drag coefficients.

Figure 50: Drag & lift coefficients history plot.

The comparison of the computed drag coefficient to other experimental and numerical
results is reported in Figure 51; as we can see our result is in good agreement with both exper-
imental and numerical data from literature, even if it is computed through a RANS simulation
with a not so refined mesh.

Figure 51: Computed drag coefficient vs other results (from [2]).

− File→ Save Project and close Fluent.
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2.4 Visualization of results in CFD-Post
In WB, right click on Results→ Edit to launch CFD-Post (Figure 52):

Figure 52: Starting CFD-Post from WB.

− In the Outline tab, under Cases → Ahmed_body → enclosure-enclosure, select only the
ahmed_surface and the ground components. Click on the Location icon and select
Line, then specify the marked settings as in Figure 53→ Apply:

Figure 53: Location definition.
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− Click on the Streamline icon and specify the marked settings as in Figure 54→ Apply,
to view the streamlines in the symmetry plane in the rear separation zone:

Figure 54: Streamline definition.

A comparison between computed and experimental (mean) streamlines along the symmetry
plane in the rear separation zone is reported in Figure 55: although the relative position of re-
circulation bubbles is not exactly computed, we can see that an approximate width of 200mm
is computed with good agreement to the experimental width.

Figure 55: Comparison of streamlines in the rear separation zone (from [4]).
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A comparison between computed and experimental (mean) streamwise velocity profiles along
the symmetry plane in the rear separation zone is reported in Figure 56: the computed profiles
show a discrete agreement with experimental ones.

Figure 56: Comparison of streamwise velocity profiles in the rear separation zone (from [3]).

CFD-Post is a powerful tool to analyze and display the results of a CFD simulation in a
graphical way; be careful to choose a meaningful way to present your results (see Figure 57).

Figure 57: Suggestive CFD image with CFD-Post.
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