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1 Introduction 1

1 Introduction
This document is a detailed description how to perform a CFD (Computational Fluid Dynam-
ics) simulation with ANSYS CFX 16.2 (hereafter ”CFX”) of a simple centrifugal pump. The
geometry, as well as experimental and numerical results are described in [1]. The geometry of
the case is provided in three .stp files. The goal is to create computational grids, make a CFX
setup file and run the simulation.

2 Case description
Centrifugal pumps are widely used sin engineering applications. Therefore, the current doc-
ument instructs to create computational grids (meshes) for a given geometry and to prepare a
setup for the CFD simulation.

The presented case is a very simple shrouded centrifugal pump impeller (Fig. 1), the
(scaled) Grundfos CR4, with medium specific speed. The PhD thesis by Pedersen [1] in-
cludes experimental and CFD results for the pump. The experiments were performed for a
transparent impeller (produced in perspex) by Particle Image Velocimetry (PIV) (Fig. 2) and
Laser Doppler Velocimetry (LDV) techniques. The CFD analysis was performed with Large
Eddy Simulation (LES).

Figure 1: Geometry of the pump impeller [1]

The experimental observations at the design operating conditions (Q = Qd) did not show
separation in blade passages, and flow in all six channels was similar. On the other hand,
at quarter-load conditions (Q = 0.25Qd) a non-rotating stall was observed, consisting of
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2 3 Analysis with ANSYS CFX

Figure 2: Details of the PIV setup [1].

alternate stalled and unstalled passages. In the latter case, flow in every second passage was
similar.

3 Analysis with ANSYS CFX

3.1 Geometry

Currently, the provided impeller geometry is an approximation of the geometrical data (Ta-
ble 1) provided in [1].

Dati caratteristici del problema.

Inlet diameter D1 = 77 mm
Outlet diameter D2 = 190 mm
Inlet height b1 = 13.8 mm
Outlet height b2 = 5.8 mm
Number of blades Z1 = 6 -
Blade thickness ti = 3 mm
Inlet blade angle β1 = 19.7 °
Outlet blade angle β2 = 18.4 °

Table 1: Impeller characteristics [1].

Usually, the computational domain of interest is extended with an inlet and an outlet
part/domain. In our case, for the impeller in Fig. 1 an inlet extension and an outlet extension
should be provided. The inlet extension provides a more realistic inlet conditions, whereas the
outlet one provides more realistic conditions (velocity vectors) at the outlet from the impeller.
For instance, if there is a large vortex at the outlet from the impeller, the outlet or opening
boundary conditions at the impeller outlet surface might produce incorrect results.
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3.2 Computational grids - ANSYS ICEM 3

Therefore, we will be using three computational ’domains’ of our CFD simulations: inlet,
impeller and outlet domain. The geometry is provided by three files. In Table 2 the relation of
filenames and computational domains is provided. The whole geometry is provided for a 60°
section (1/Z1 of the full circle).

Filename Part No. in Fig. 3 Computational domain

geometry inlet3.stp 1 inlet
geometry impeller3.agdb 2 impeller
geometry outlet3.stp 3 outlet

Table 2: Geometry filenames and computational domains.

Figure 3: Geometry, specified by three geometry files

In the following section it will be described how to create computational grids for the three
geometry files.

3.2 Computational grids - ANSYS ICEM
Computational grids for all three parts (provided by three geometry files) will be created in
ANSYS ICEM. It is suggested to put each geometry file in a separate file directory.

3.2.1 Computational grid 1

Start ANSYS ICEM by clicking Tutti i programmi→ ANSYS 16.2→ Meshing→ ICEM CFD
16.2. Set the working directory of the first file (geometry inlet.stp): File→ Change Working
Dir....
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4 3.2 Computational grids - ANSYS ICEM

Open geometry file of part 1: Click File→ Import Geometry→ Legacy→ STEP/IGES,
select a file, click Open, then click Apply in the window presented in Fig. 4.

Figure 4: Importing the geometry file.

The geometry is imported. Save the project to select project’s name: File→ Save Project
As..., write mesh inlet.prj and click Save.

In the window that represents geometry the left mouse button (LMB) rotates the geometry,
the central mouse button (CMB) moves geometry and the right mouse button (RMB) scales
up/down the geometry. In the left region of the screen a Display Tree (Fig. 5) is shown, which
can be used for control of display in the main window. It is possible to click on the + sign to
expand the tree.

Figure 5: Display Tree.

The imported part represents an inlet part above the impeller in Fig. 2. From the figure it
can be concluded that side walls of the inlet geometry do not rotate.

The first step is to set the correct units and size. Click (LMB) Settings → Model/Units.
Set the units to Milimeters and click OK. The geometry size should be increased by 1000
times. In the Main Toolbar click Geometry → Transform Geometry: . Use the settings
according to Fig. 6 and click . Enable selection of points, curves, surfaces and bodies in the

floating menu (choices in the menu should be enabled). Then press ”a” on
the keyboard (shortcut for ”select all”) and click Apply. Click Fit Window icon ( ) to fit the
geometry in the screen window.
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3.2 Computational grids - ANSYS ICEM 5

Figure 6: Scaling the geometry by a factor of 1000.

The next step is the creation of the ”parts” in the Display Tree, which will later represent
selectable surface parts of the meshes for which we will prescribe boundary conditions. An-
other advantage of creation of parts is the prescription of element size for each part (in case
of unstructured grids).

Five parts will be created in the Display Tree of the mesh inlet.prj project: geom1 in,
geom1 out, geom1 walls, geom1 per1 and geom1 per2 (the ’geom1’ label was used to repre-
sent the inlet part/domain of the whole case).

Rotate the geometry so that Zaxis is pointing upward, turn on surfaces in the Display Tree
and click on solid simple display icon in the Main Menu. The result is presented in Fig. 7.

To create a part (containing a surface) the following procedure can be used:

• Right-click on Parts, then left-click on Create Part

• Enter(write) the part’s name in the top field

• Click on icon next to Create Part by Selection. The most important functionality of
the pop-up window is to toggle on/off selection of points, curves, surfaces and bodies
by clicking the four icons. Turn on only the selection of surfaces:

• Pick-up the desired surface(s) by left-clicking (LC) on surface(s), then finish with a
middle-button-click (MC). Before finishing it is possible to undo the picking-up actions
(in a reverse direction) by using a right-mouse button (RC). During the pick-up process
it is possible to rotate/move the geometry by pressing F9 button (and re-pressing to
re-enter the pick-up process).
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Figure 7: The geometry of the first domain (inlet domain) before creation of parts.

• MC again to finish the selection process.

• A new part appears in the Display Tree and the part’s surface(s) change its(their) colour.

By using the described procedure create the five parts. The part geom1 in includes the
inlet surface (with the highest Z value) - the surface at the top in Fig. 7. The part geom1 out
includes the outlet surface (with the lowest Z value). The part geom1 walls includes the
annular section/surface. There should be two periodic parts. Suppose that index Per1 of the
periodic parts is on the left side of index 3 in Fig. 3 (for geometry 3), whereas index Per2 is
on the right side of index 3. Therefore, the part geom1 per1 is the visible vertical surface in
Fig. 7, whereas the part geom1 per2 is the hidden vertical surface in Fig. 7.

In the Main Toolbar click Geometry→ Create Body: .
Turn on points visibility and turn off visibility of surfaces in the Display Tree. Create a

body (part) named BODY INLET by using Centroid of two points and picking up two points
(e.g., as in Fig. 8). MC twice. Check that the centroid (body) point lies within the geometry,
bounded by surfaces (rotate the geometry to check it).

In the Main Toolbar click Mesh→ Global Mesh Setup: . Set the global mesh parame-
ters according to Fig. 9 (Max element size=4.0, Prism initial height=0.1, ratio=1.2, layers=10,
Rotational period. axis = 0 0 1, angle=60). Click Apply in each of the three windows. It
should be noted that in some cases (complex ones) the creation of prism layers mail fail with
the latter setting. In such cases it is better to set only two parameters for prism elements (thus
leaving the total prism height ’floating’). For instance, set only the ratio with e.g. 7 layers,
and later subdivide and rearrange the layers (as it will be done for the blade mesh).

Besides setting the global parameters it is possible to set local parameters for specific
parts. In the Main Toolbar click Mesh→ Part Mesh Setup: . A pop-up window appears.
Choose parameters accurding to Fig. 10 (BODY INLET part will have a hexa core mesh,
max. size=4, prism layers will be located at part GEOM1 WALLS). Instead of putting 4 to
the max size it would be possible to leave the setting as 0, because of the previously defined
global parameters. Prism elements are needed only at walls. The hexa-core mesh converts
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Figure 8: Create Body: selection of two points.

Figure 9: Global mesh setup.
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8 3.2 Computational grids - ANSYS ICEM

tetrahedral elements to haxagonal elements, thus reducing number of elements (decreased
elements vs. nodes ratio). To finish, press Apply, then Dismiss.

Figure 10: Part mesh setup.

After defining the mesh parameters it is time to create the mesh. In the Main Toolbar
click Mesh→ Compute Mesh: . In the Compute Mesh window turn on creation of prism
layers and mesh hexa-core after the tetra meshing (Fig. 11). It would be also possible to create
prism layers and hexa core in a separate meshing process. This can be useful for complicated
geometries, where it is better to create a high-quality tetra mesh first (quality above 0.2 or
0.3). Press Compute.

Figure 11: Compute Mesh window.

To view the mesh (if it is not visible) turn on Shells in Mesh tree of the Display Tree, as
well as surface parts, left-click in the Main Toolbar, then click Fit Window icon in the
Main Toolbar. The mesh is presented in Fig. 12.

Check the mesh for errors. Click Edit Mesh → Check Mesh ( ). Click Apply. A pop-
up window appears. Select the two periodic parts and click Accept. Confirm the deletion of
unconnected vertices (click Yes).
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Figure 12: Mesh - inlet part.

Check the quality of the mesh. Click Edit Mesh→ Display Mesh Quality ( ). The mesh
quality is just above 0.2.

Improve the mesh quality. Click Edit Mesh → Smooth Mesh Globally ( ). Set the
smoothing parameters according to Fig. 13. Click Apply. The new quality is above 0.25. If it
was smaller, the smoothing would be repeated with quality limit set to 0.2 and all previously
’Frozen’ types of meshes set to ’Smooth’.

Repeat the previously described Check Mesh step.
Click File→ Save Project.
The mesh has to be exported to a .cfx5 file format. Click Output → Select solver ( )

and set the field Output solver to ANSYS CFX. Click Apply. Then click Output→Write input
( ). Confirm saving the project. Click Done in another pop-up window. Wait until you see
’Done with translation’ message in the Message window. The mesh is exported. Now close
the project (you can as well save it).

3.2.2 Computational grid 2

Start ANSYS ICEM by clicking Tutti i programmi→ ANSYS 16.2→ Meshing→ ICEM CFD
16.2. Set the working directory of the second geometry file (geometry impeller3.agdb): File
→ Change Working Dir....

Open geometry file geometry impeller3.agdb: Click File → Import Model, select a file,
click Open, in the menu set units to Milimeter and then click Apply.

Save the project to select project’s name: File→ Save Project As..., write mesh impeller.prj
and click Save.
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Figure 13: Smoothing the mesh.

Click Settings → Model/Units in the Main Menu. Set Topo Tolerance to 0.0008 and
Triangulation Tolerance to 0.00001, then click OK.

Create the following surface parts (remember, the Surfaces in the Display Tree should be
enabled for the selection of the surfaces):

• geom2 in,

• geom2 out,

• geom2 blade LE,

• geom2 blade PS,

• geom2 blade SS,

• geom2 blade TE,

• geom2 hub,

• geom2 shroud,

• geom2 nowalls top,

• geom2 nowalls bottom,

• geom2 per1,

• geom2 per2.

A. Škerlavaj, E. Nobile - May 2016



3.2 Computational grids - ANSYS ICEM 11

The surface parts are presented in Fig. 14 and Fig. 15. The inlet surface is the one at the largest
value of Z. The index LE stands for leading edge of the blade (small surface), TE stands for
trailing edge of the blade (small surface), the SS is suction side and the PS is pressure side.
Hub is the (non-curved) surface at the impeller bottom (at the lowest value of Z), whereas
shroud are the two curved surfaces opposite to the hub. The top and the bottom surfaces at the
largest radius (after the TE), marked geom2 nowalls, do not represent the impeller. They are
there just for numerical purposes. Create a body with name BODY IMPELLER.

Figure 14: Surface parts of the impeller blade.

Figure 15: Surface parts of the impeller blade.

Delete two curves and six points, as presented in Fig. 16. Create part POINTS with all
points in the geometry. Create part CURVES that should contain all curves in the geometry.

Set the global mesh setup: in the Main Toolbar click Mesh → Global Mesh Setup: .
Set the global mesh parameters according to Fig. 17 (Max element size=4.0, Tetra edge crite-
rion=0.05, No. of prism layers=1, Rotational period. axis = 0 0 1, angle=60). In addition, in
the Global Prism Settings, set the Number of surface smoothing steps to 0. The height of the
channel at the outlet from the impeller is equal to 5.8 mm, which is similar to the maximum
size of the mesh element. Therefore, only one prism layer was created, which will be later
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Figure 16: Curves and points. Blue: curves to be deleted. Red: points to be deleted. Green:
curves to be set with Curve Mesh Setup.

subdivided into more layers. The tetra edge criterion was decreased to capture the curves of
the trailing edge properly (otherwise the trailing edge might become jagged).

The next step is setting parameters of the mesh for the parts. In the Main Toolbar click
Mesh→ Part Mesh Setup: . A pop-up window appears. Choose parameters accurding to
Fig. 18 (BODY IMPELLER part will have a hexa core mesh, max. size=2, prism layers will
be located at all walls). The size of the hub, shroud and nowalls parts is 2.5, and remains so
for two layers away from the surface (tetra width). To finish, press Apply, then Dismiss.

The last step of the mesh setup will be a setup of elements sizes on two curves at the
trailing edge of the impeller. In the Main Toolbar click Mesh→ Curve Mesh Setup: . For
the two curves indicated in Fig. 16 set the parameter ’Number of nodes’ to 8.

Now the mesh can be computed. In the Main Toolbar click Mesh→ Compute Mesh:
. In the Compute Mesh window turn on creation of prism layers and mesh hexa-core after
the tetra meshing (Fig. 11). Press Compute. At the trailing edge, the mesh will look like as
presented in Fig. 12.

Since the prism elements consist of only one layer, we have to subdivide it. In the Main
Toolbar click Edit Mesh→ Split Mesh: . Set the parameters according to Fig. 20: Prism
Volume Parts=BODY IMPELLER (click on the icon), No. of layers=5. Click Apply. After-
wards, the mesh at the outlet from the impeller will look like as presented in Fig. 13. Note:
in general, there should be 10-15 prism layers in the boundary layer due to wall function
requirements.

Check the mesh for errors. Click Edit Mesh → Check Mesh ( ). Click Apply. A pop-
up window appears - select the two periodic parts and click Accept. Confirm the deletion of
unconnected vertices (click Yes).

Check the quality of the mesh. Click Edit Mesh→ Display Mesh Quality ( ). The mesh
quality is below 0.2.

Improve the mesh quality. Click Edit Mesh → Smooth Mesh Globally ( ). Set the
smoothing parameters according to Fig. 13. Click Apply. The step can be repeated with the
quality limit set to 0.1, with Prism and Pyramid elements set to ’Smooth’.

Repeat the previously described Check Mesh step and save the project (click File→ Save

A. Škerlavaj, E. Nobile - May 2016



3.2 Computational grids - ANSYS ICEM 13

Figure 17: Global mesh setup for the impeller blade.
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Figure 18: Part mesh setup for the impeller blade.

Figure 19: Single layer of prisms. Sharp trailing edge.

Figure 20: Split Prisms setup.
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Figure 21: Prism layers at the impeller outlet after subdivision of the initial layer.

Project). As in the previous chapter, export the mesh. Close the project.

3.2.3 Computational grid 3

Start ANSYS ICEM by clicking Tutti i programmi → ANSYS 16.2 → Meshing → ICEM
CFD 16.2. Set the working directory of the third geometry file (geometry outlet.stp): File
→ Change Working Dir....

Open geometry file: Click File → Import Geometry → Legacy → STEP/IGES, select a
file, click Open, then click Apply in the window presented in Fig. 4.

Save the project to select project’s name: File→ Save Project As..., write mesh outlet.prj
and click Save.

Click Settings → Model in the Main Menu. Set Topo Tolerance to 0.001, Triangulation
Tolerance to 0.00001 and units to Millimeters. As for the inlet mesh, scale up the whole
geometry by a factor of 1000 (Fig. 6), then rescale the view.

Create the following parts: geom3 in, geom3 out, geom3 top, geom3 bottom, geom3 per1
and geom3 per2. The index LE stands for leading edge, the SS is suction side and the PS is
pressure side. The bottom surface is the one at the impeller bottom (at the lowest value of Z),
whereas the top one is at the largest value of Z.

Create a body named BODY OUTLET.
We will create a blocking for the block-structured mesh, with 40 evenly-distributed nodes

in the circumferential direction and 25 nodes in the radial direction. For the height of the
’channel’ 19 nodes will be used, with spacing 0.1 and ratio 1.3 from both sides. This will
result in 19,000-node mesh. In the Main Toolbar click Blocking→ Create Blocks . In the
window on the left side of the screen (Create Block window) click on the icon and press a
on the keyboard to select all the geometry. A blocking will appear in the screen (black lines
in Fig. 22).

To associate blocking vertices with points click Blocking → Associate in the Main
Toolbar. Associate all eight points, as indicated in Fig. 22, by clicking the in the Blocking
Associations windows in the left side of the screen (use selected radio button Point). To select
the vertex, LC in the field Vertex, pick a vertex (LC), then pick a point. To finish use MC.

To associate blocking edges with curves click Blocking→ Associate in the Main Tool-
bar. Then click the in the Blocking Associations windows in the left side of the screen.
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Figure 22: Blocking (black lines). Associate vertices with points (indicated with similar
colours: red to be associated with red, green with green, etc.).

To select the edge, LC in the field Edge(s), pick an edge (LC+MC), then pick a corresponding
curve (LC+MC). To finish use MC. When an edge is associated it turns green (turn off visi-
bility of curves to check it). To check the edge associations, in the Display Tree find Model
→ Blocking→ Edges and right-click Show Accociation.

To define spacing of mesh elements use Blocking → Pre-Mesh Params in the Main
Toolbar, then choose Edge Params icon ( ) in the Pre-Mesh Params window on the left. Do
not forget to turn on the tick at Copy Parameters (To All Parallel Edges).

The next step is to take care of the periodicity. Define the 60-degree periodicity, as in
the right-hand-side part of the Fig. 9. In the Main Toolbar click Blocking→ Edit Block: .
In the Edit Block menu on the left, click Periodic Vertices: . Choose (set) the pairs of
periodic vertices, as indicated in Fig. 23. The periodicity of vertices, as presented in Fig. 23,
can be observed by displaying the vertices in the Display Tree Menu and choosing (RMC on
Vertices) Periodic.

Figure 23: Periodic vertices (indicated by red arrows).

Create a pre-mesh: in the Display Tree RC on Pre-mesh under the Blocking tree, then
choose Recompute. Turn on the visibility of pre-mesh. By using the blocking parameters
described previously, the blocking should look like as in Fig. 24.

Check the pre-mesh quality: click Blocking → Pre-Mesh Quality Histograms in the
Main Toolbar, choose Quality for the criterion. Click Apply. The result should be close to 1.

Convert the blocking to unstructured mesh (in the Display Tree RC on Pre-mesh under the
Blocking tree, then choose Convert to Unstruct Mesh).
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Figure 24: Pre-mesh of the outlet geometry.

Save the project (click File→ Save Project). Export the mesh. Close the project.

3.3 Numerical setup - CFX-Pre
After creating the 3 meshes it is possible to create a numerical definition (.def) file. The
file will contain the 3 meshes, information about the simulation type, boundary and initial
conditions, the models used, etc.

Start ANSYS CFX from CFX Launcher by clicking Tutti i programmi→ ANSYS 16.2→
Fluid Dynamics→ CFX 16.2. Set the working directory. Then click CFX-Pre 16.2.

Create new case (CTRL+N). If asked, choose General simulation type and click OK in
the information window that follows. Save the case as ’impeller Qd.cfx’.

To import the three meshes, use File → Import → Mesh. Choose the directory where
mesh(es) is(are) located, set ’Files of type’ to ICEM CFD (*cfx *cfx5 *msh) and units to mm.
Then click on the mesh file to select it and click on button Open.

The design operating point for the pump impeller with outer diameter 190 mm [1] is
defined with rotational speed (n = 725 rpm), flow rate at best-efficiency point (Qd = 3.06 l/s)
and head (Hd = 1.75 m).

A steady-state simulation will be performed. The default type of a simulation is a steady-

state one, which can be checked by clicking the icon in the Main Toolbar.
First of all, we have to create three domains because the inlet and outlet meshes are in

non-rotating domain, whereas the impeller is in a rotating one. The domain is created by

clicking the icon in the Main Toolbar. Create the domain names as specified in Table 3,
in the Domain window use the locations as specified in the table.

Domain Name Mesh (location)

dom inlet BODY INLET
dom impeller BODY IMPELLER
dom outlet BODY OUTLET

Table 3: Domain names and corresponding mesh(location) names.
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Material selection: double-click on one of the created domains and set Basic Settings→
Fluid and Particle Definitions... → Fluid 1→ Material to Water. Click OK.

Heat transfer will not be used: double-click on one of the created domains and set Fluid
Models→ Heat Transfer→ Option to None. Click OK.

The Shear Stress Transport (SST) turbulence model will be used: double-click on one of
the created domains and set Fluid Models→ Turbulence→Option to Shear Stress Transport.
Click OK.

For the impeller domain prescribe angular velocity: double-click the domain and set Ba-
sic Settings → Domain Models → Domain Motion to the following values. Set ’Option’ to
Rotating and set ’Angular Velocity’ to 725 [rev minˆ-1] . Leave ’Rotation Axis’ set to Global
Z. Click OK.

To define the boundary conditions (BCs) in a specific domain, use a pull-down menu from

the icon , which is located in the Main Toolbar. Mass flow rate through the inlet BC is
equal to (3.06 l/s * 997 kg/m3)/6. Set the BCs according to Table 4.

Domain BC Name Type Location Boundary Details

dom inlet in Inlet GEOM1 IN Mass Flow Rate,
0.5085 kg/s

dom impeller blade LE Wall GEOM2 BLADE LE No Slip Wall
dom impeller blade TE Wall GEOM2 BLADE TE No Slip Wall
dom impeller blade SS Wall GEOM2 BLADE SS No Slip Wall
dom impeller blade PS Wall GEOM2 BLADE PS No Slip Wall
dom impeller walls Wall GEOM2 HUB, No Slip Wall

GEOM2 SHROUD
dom impeller slip1 Wall GEOM2 NOWALLS BOTTOM, Free Slip Wall

GEOM2 NOWALLS TOP
dom outlet out Outlet GEOM3 OUT Aver. Stat. Pressure,

0 Pa
dom outlet slip2 Wall GEOM3 TOP, Free Slip Wall

GEOM3 BOTTOM

Table 4: Boundary conditions.

To define the domain interfaces click the icon in the Main Toolbar. Set the interfaces
according to Table 5. In case the stage interface set the pitch ratio option to None, whereas for
the frozen rotor interface specify pitch values equal to 60° at both Side 1 and 2 of the GGI.

To define the expressions, as specified in Table 6 use the icon in the Main Toolbar.
Another possibility is to import the expressions (import (append) the file expressions2016.ccl).

The impeller efficiency is calculated as a ratio between hydraulic power Phyd and shaft
power Pt. Hydraulic power is equal to Phyd = ∆ptotQ = %gHimpQ, where Q is volume
flow and ∆ptot a difference in total pressures between outlet and inlet from/to the impeller.
The Himp is the head difference expressed in [m] between the impeller outlet and impeller
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Name Region1 Region2 Interf. Model Mixing Model

GGI inl imp GEOM1 OUT GEOM2 IN General Conn. Frozen Rotor
GGI imp out GEOM2 OUT GEOM3 IN General Conn. Stage
GGI per1 per2 all three PER1 all three PER2 Rotational Period.

Table 5: Domain interfaces.

Name Expression

dens 997 [kg mˆ-3]
nrot 725
omega (2*pi*nrot)/60
mFlow abs(massFlow()@in)
TorLE torque z()@blade LE
TorTE torque z()@blade TE
TorPS torque z()@blade PS
TorSS torque z()@blade PS
TorChanWalls torque z()@walls
Tor abs(TorChanWalls+TorLE+TorTE+TorPS+TorSS)
H1 massFlowAve(Total Pressure)@GGI inl imp Side 1
H2 massFlowAve(Total Pressure)@GGI imp out Side 2
H1p areaAve(Pressure)@GGI inl imp Side 1
H2p areaAve(Pressure)@GGI imp out Side 2
Himp (H2-H1)/(dens*g)
HpImp (H2p-H1p)/(dens*g)
Eff ((H2-H1)*mFlow)/(Tor*omega*dens)

Table 6: Expressions.
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20 3.4 Numerical simulation - CFX-Solver

inlet. The shaft power (from motor to the shaft) is equal to P = Tω, where T is torque
and ω is angular velocity. In our case, the impeller outlet was moved slightly away (further
downstream) from the true outlet.

It is possible to observe results during the simulation. To do this, click Output Control

icon in the Main Toolbar. Go to ’Monitor’ tab, enable Monitor Objects and click Add
New Item icon at the bottom.

To monitor efficiency, enter name ’mon eff’, then use ’Option’ Expression and in the
’Expression Value’ RC(right-click) → Expressions → ’Eff’. Click Apply. Similarly, enter
monitor point ’mon Himp’ for the ’Himp’ expression, ’mon HpImp’ for the ’HpImp’ and
’mon Tor’ for the ’Tor’ expression.

The last setup that remains is the Solver Control setting . Set the parameters according
to Fig. 25. In the same figure the geometry, with some BCs, is visible.

Figure 25: CFX-Pre window with Solver Control settings on the left and geometry and BCs
on the right.

Save the file. Click Define Run icon , then Save to save the .def file. A CFX-Solver
window appears. Now you can close the CFX-Pre.

3.4 Numerical simulation - CFX-Solver
Define the run settings, then click Start Run. To observe the predefined monitor points click
Workspace→New Monitor, define name (eg. ’eff’), then click OK. Finally, associate the en-
tered name with the monitor point and choose the min. and max. values Fig. 26.

3.5 Postprocessing - CFX-Post
When the Solver is finished it is possible to check the results in CFX-Post. One option is
to click the icon in CFX-Solver. Another option is to click CFD-Post 16.2 in ANSYS
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Figure 26: Define monitor points in CFX-Solver.

CFX-16.2 Launcher ( Tutti i programmi→ ANSYS 16.2→ Fluid Dynamics→ CFX 16.2).
The experimental results ([1]) are presented in Fig. 27. The left graph is presented for

the original size of the impeller, whereas the right graph is scaled from the left one, for the
scaled-up impeller by a factor of two. Our CFD results should be compared to the right graph.
Comparison of design parameters of both impeller sizes is presented in Table 7.

It seems that the Head presented in Fig. 27 is actually a pressure difference, since in [1], p.
116, the author mentiones that the design total head is 2.6 m, based on velocity measurements.
Total head, predicted by our cfd simulation, is approximately 2.22 m, whereas the pressure
difference is approximately 1.725 m (both predicted at slightly larger outlet radius).

Experimentally obtained [1] relative speed W distribution and vectors are presented in
Fig. 28 and Fig. 29. Experimental results for vorticity are presented in Fig. 30. Results for
deviation angle are represented in Fig. 31.

Table 7: Design parameters of original and scaled CR4 impeller [1].

CFD results for stage and frozen rotor general-grid interface at the outlet from the impeller
are presented in Fig. 32 and Fig. 33.
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Figure 27: Experimental results [1]. Left: Performance and efficiency for original (non-
scaled) CR4 impeller. Right: Performance curve for scaled test impeller as predicted by
similarity laws. Stars represent design points.

Figure 28: PIV ensemble averaged relative speed W at design operating point [1].
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Figure 29: Vector plot of relative velocity W measured with LDV at radii r/R2 =
{0.5, 0.65, 0.75, 0.9, 1.01} for design operating point [1].
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Figure 30: Vorticity in Z direction for design operating conditions [1]. a) Instantaneous sam-
ple; b) Ensemble average.

Figure 31: Ensemble averaged deviation angle 〈∆β〉 = 〈β〉 − β2 between relative flow angle
β = atan(Wr/Wt) and the outlet blade angle β2 = 18.4°. Wr represents relative radial veloc-
ity, Wt represents relative circumferential velocity. Experimental result for design operating
conditions [1].
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Figure 32: Comparison of Velocity in stationary frame at both sides of the GGI, for stage and
frozen rotor type of the GGI.

Figure 33: Comparison of Velocity and Velocity in stationary frame in a plane at Z=29 mm,
for stage and frozen rotor type of the GGI.
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