
PREPARATION OF IMAGES AND MOVIES OF PROTEIN STRUCTURES 
USING THE UCSF CHIMERAX SOFTWARE. 

 
The UCSF ChimeraX software [1] is a tool that allows the visualization of protein structures and electron density 
maps obtained through biocrystallographic or electron microscopy techniques, the comparison of protein 
conformations, the production of images and small movies of good quality, both of the overall structure and 
of local details. As input, the software requires a pdb file of a structure, or an electron density map file (usually 
in ccp4 format, file type .map). Tutorials are available on the software website [2] and on the website of the 
Brown Lab research group at Virginia Tech University [3]. On the software website, a summary page lists all 
the available commands and their syntax [4]. 
 
Opening of a pdb file and general options for viewing protein structures 
When the program starts, a pdb file can be opened on the graphic window (1) by selecting it from the drop-
down menu File > Open item (2). 
Alternatively, if the software has already been previously opened, a list of opened structures appears on the 
left of the window (3). A single click on the name of a structure opens the file. 
Furthermore, it is possible to directly obtain a file from PDB or other databases: select the drop-down menu 
File > Fetch by ID; a dialog window opens; search for the structure in one of the available databases using the 
specific code (4). 
 

 
 

In addition to the display panel (3), the main window contains a panel with the list of previous commands (Log, 
5) and the list of models displayed on the main window (6). From the latter list, it is easy to select what to 
display and what to remove. At the bottom, a command prompt allows typing the commands (7). 
 
In the Log panel (5), available information about the structure is displayed when a new pdb file is opened. 
Sometimes, it is useful to copy the commands provided to be able to reproduce the activity of a previous 
session; in this case, however, this has to be done manually, as the Log panel is not saved automatically. 
The Models panel (Models, 6) contains the name of the model (8) (usually the name of the pdb file), the 
identification number the software assigns to each model (9), and the color of the model (10). The 
identification number must be used for the selection of a specific model (or part of it) preceded by the symbol 
# (see below). Two columns show which models are on display (11) and selected (12). The color of a model 
can be changed from this panel, by clicking on the color in the specific column (10). If only part of a model has 
been selected, a black square symbol (13) appears in the selection column. 
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In the main window of the software, at the top, there are several tabs that open the software menus. Among 
these, the Right Mouse tab (last in the row, 14) allows you to select the action to be performed by clicking on 
the right mouse button. This is very useful when you do not have a 3-button mouse or a mouse with a wheel. 
When the software opens, the mouse controls are as follows: left button for rotation, right button for 
translation, middle button for zoom. You can change the command linked to the right button by selecting the 
appropriate icon in this menu. For example, by selecting the Drag Model icon you can change the position of 
just one of the models, when several are on display, and superimpose two models for comparison. 
 

 
 
Several display options are available from the second tab (15), Molecule Display. Furthermore, the same result 
can be obtained by typing the appropriate commands in the prompt (7).  
 

 
 
 

The first sections of this tab (16-18) allow activating or deactivating the display of atoms, chains as cartoons 
and surfaces, respectively. The following sections change the display style of the atoms (19) and their color 
(20). After opening the pdb file, you can display all atoms with the Show button in the Atoms section (16). The 
same result can be obtained by typing in the command line:   

> show atoms 
In the Home tab (21), a series of options allow you to optimize the display of the model, for example improving 
the lighting (22) or changing the background color (23). Some of the display options in the Molecule Display 
tab are repeated in this tab. To change the background, type on the command line:  

> set bgColor white 
 

 
 
Other display options are available in the Graphics tab (24). In particular, the View selected (25) and View all 
(26) options allow you to center the display panel on a region of the selected protein (for selection options, 
see below) or on all the models that are currently loaded and displayed by the software, respectively.  
Alternatively, type on the command line: 
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> view <selection> [to center the display on a specific portion of the model] 
> view    [to center the display on all currently visualized models] 

 

 
 
A useful tool is the lateral view of the display space (27, Side view), which opens a new window (28)that allows 
the positioning of the frontal (29) and posterior (30) planes of the view.  
The orthoscopic (i.e., without perspective) view (31) is generally preferred for protein images, because it does 
not present deformations due to the position of the focus of the perspective. The orthoscopic view of the 
model can be activated from the command line by typing:  

> camera ortho.  
 

 
 
 
Selection syntax and display/coloring commands 
Often, it is useful to select and display only some residues of the protein to analyze their structure in detail, 
for example when we are interested in the catalytic site residues of an enzyme. In this case, the portions of 
interest can be selected using the Select menu or from the command line. 
In the Select menu several items are available, including: 

- Chains, which allows the selection of the polypeptide chains present in the pdb file; 
- Chemistry, with several sub-items that allow the selection an element type or functional group, or all 

the atoms of the protein, or if present the nucleic acids; 
- Residues that allows the selection of a specific residue type (e.g., all the histidine residues present in 

the structure); 
- Structure that allows you to alternatively select the atoms of the main chain, the side chains, the 

ligands, ions, or portions of the protein with a defined secondary structure; 
- Sequence that allows you to select a specific sequence. 

From the Select menu we can chose a mode for the next selection: usually, the second selection replaces the 
first (Replace), which is the default option, but you can also add a second selection to the first (Add), or identify 
the intersection between the second and the first (Intersect), or subtract the second selection from the first 
(Subtract). 
The selection can be cancelled with: Select > Clear. 
For example, aiming to select all the acidic residues of the protein, including both the aspartate and glutamate 
residues: 

○ click on Select > Residues > Asp,  
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○ modify the selection method with Select > Menu Mode > Add (when this mode is activated, a + symbol 
appears on the menu, Select+),  

○ finally, select glutamate residues by clicking on Select > Residues > Glu. 
 
Alternatively, you can select the portions of interest from the command line, using the select command. In 
short, the basic syntax of this command is: 

> select #1  [selects the whole model #1; the identification number of each model is displayes in 
column ID (9) of the Models panel (6)]. 

> select /A  [selects chain A in all the available models]. 
> select :1-84  [selects residues from 1 to 84 in all chains of all available models]. 
> select :Asp  [selects all aspartate residues in all available models]. 
> select @C*  [selects all carbon atoms in the available models. Using @CA as a specifier, 

one can select all carbon  atoms of the available models]. 
These selection options can be combined using the logical operators and (&), or (|) and not (&~). Furthermore, 
it is possible to combine the selection options even without using the logical operators, but always respecting 
the hierarchy: #model > /chain > :residue > @atom. 
For example, if you want to select all the acidic residues (aspartate and glutamate) of the B chain of the protein 
identified as model #3, you will write on the command line: 

> select #3/B:Asp|#3/B:Glu. 
To delete the previous selection:  

> select clear. 
You can assign a name to a defined portion of the structure, to be able to recall it later: 

> name <name of the selection> <identifiers of the selected portion>.  
In the previous example:  

> name acidic_res_B  #3/B:Asp|#3/B:Glu. 
 
Once the portion of interest has been selected, it can be displayed with one of the display options offered by 
the program from the Molecule Display tab (see above, 15). Alternatively, you can type the commands show, 
hide, and color on the command line: 

> show acidic_res_B atoms  [shows atoms of the selected residues as sticks] 
> hide /B cartoon    [hides the cartoon visualization of chain B] 
> color :127-234 red   [colors in red residues 127-234 of all protein chains]. 

Other visualization options can be used with the commands show/hide, among these: 
atoms/cartoons/ribbons/surfaces. 
For a complete list of color names recognized by ChimeraX, see reference [5]. 
 
Visualization of symmetry-related molecules 
When a crystallographic structure is loaded, the program displays only the contents of the pdb file, which 
correspond to the asymmetric unit. However, it is possible (and in many cases useful) to display also symmetry-
related molecules. This is the case, for example, of a protein with a quaternary structure in which a 
crystallographic symmetry element coincides with the symmetry of the quaternary structure. The functional 
protein in this case can only be obtained by applying the crystallographic symmetry to the asymmetric unit. 
To display symmetry-related molecules, you need the information about unit cell and symmetry reported in 
the CRYST1 line of the pdb file, which is automatically read by the software when you open the pdb file.  
 
To display symmetric molecules, select: Tools > Higher-Order Structure > Crystal Contacts. At this point, a 
window allows you to define the contact distance of the symmetric units that you want to be displayed: the 
software will display all symmetry-related molecules that are closer than the defined threshold. For each 
symmetry-related copy, the Log panel (5) reports the symmetry operator and the translations applied. 



Furthermore, in the Models panel (6) the symmetry-related molecules are reported as a new object. In this 
panel you can select which molecules you want to display or hide, by ticking the appropriate boxes in the 
column with the eye symbol, 11). 
  
Alternatively, you can achieve the same result from the command line by typing: 

> crystalcontacts #<model> distance <in Å>  
and then, if necessary, hiding some of the symmetry-related molecules with the command: 

> hide #<model>.<symmetry-related molecule> cartoons 
(the numerical code of each symmetry-related molecule is reported in the Models panel, 6). 
 
For example, when opening the structure with PDB code 3zrs (bacterial KIR-type potassium channel), the 
software only shows a monomer (32), which represents the asymmetric unit of the structure, but not its 
functional unit (the protein is homotetrameric). With the following command we can display the symmetry-
related molecules, obtaining the visualization of the tetramer (33): 

> crystalcontacts #1 distance 2.  
 
 

   
 
 
How to measure distances, angles and torsion angles 
To measure the distance between two atoms, first select the atoms using the left mouse button, together with 
the Ctrl and Shift keys. At this point, select Tools > Structure Analysis > Distance. This command opens a dialog 
box (34) to measure the distance and select the measurement display options (35). Press the Create button 
(36) in the window to measure the distance. At this point, the distance appears in the dialog box (37), while 
the display panel shows a dashed line between the selected atoms.  
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You can obtain the same result by typing the distance command with the references of the selected atoms. 
For example: 

> distance #1/A:127@O #1/A:124@N  [measures the distance between the 
carbonyl oxygen atom of residue 127 of chain A and the amide nitrogen atom of residue 124 of the 
same polypeptide chain]. 

 
To measure the angles and torsion angles, you can use the second tab of the same window (38), selecting 3 or 
4 atoms, respectively, and pressing the Create button. In the figure, an example of measurement of the angle 
between a nitrogen atom of the heme group, the iron atom and another nitrogen atom (hemoglobin structure, 
PDB code 6r2o) (39). In the second and third rows, examples of measurement of the torsion angles  and  
for a single residue of the structure (40). 
 

 
 
From the command line, you can display in the Log panel (5) the same angle or torsion angles, respectively, by 
typing the following commands: 

> angle /D:201@NA /D:201@FE /D:201@ND 
> torsion /A:123@C /A:124@N /A:124@CA /A:124@C [for the  torsion angle] 
> torsion /A:124@N /A:124@CA /A:124@C /A:125@N [for the  torsion angle]. 

 
 
 
Comparison of the structures of homologous molecules 
To compare the 3D structure of proteins, graphical tools are indispensable. ChimeraX can perform this 
comparison overlaying homologous structures in order to minimize the distance between corresponding 
residues. This operation can be performed either through the menus or from the command line. 
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Selecting from the top menu Tools > StructureAnalysis > Matchmaker, a new window opens (41) where you 
can select the structures you want to overlay. In the left column (42), select the structure that will be used as 
a reference (i.e. the structure that in the overlay remains in the initial position); in the right column (43) select 
the structure to overlay. The overlay can also be performed only on a previously selected part of the structure, 
by ticking the box (44) under the list of structures. More sophisticated tools include the alignment of protein 
sequences (Alignment) or the optimization of the overlay through iterative cycles (Fitting).  
 

 
  
 
 
Preparing images of the protein structure 
Before saving an image, it is advisable to optimize the position of the model that you want to display. You can 
use the mouse to manually perform rotations and movements of the model, and the Side View panel (28), to 
move the foreground and background planes of the display window. Thus, only the selected part of the model 
will appear in the image. 
The same result can be obtained with the clip command and option far and near: 

> clip near 20   [moves the foreground plane 20 Å closer to the observer] 
> clip near -10   [moves the foreground plane 10 Å further from the observer] 
> clip far 5   [moves the background plane 5 Å further from the observer] 
> clip far -2   [moves the background plane 2 Å closer to the observer]. 

 
The ChimeraX software allows you to prepare good quality images of the structure of interest. The images can 
be prepared by selecting the Snapshot button from the Home menu at the top (45), or by selecting File > Save. 
In the latter case, the software opens a window (46) from which you can select the type of file you want to 
save (in this case png). From this window you can define the size and quality of the image to be saved (47).  
 
The image can be saved also using the save command and options to define the pixel size (pixelsize), 
the height (height) e width (width) of the image (48): 

> save immagine.png height 600 width 200   [saves a 600 x 200 pixel png image]. 
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Preparing Movies – Commands for Positioning and Moving the Displayed Models 
The simplest type of movies that can be made with ChimeraX are those in which the model in question is 
rotated along the vertical axis of the figure (y-axis). This type of movies can be immediately saved using the 
Spin Movie button in the Images section of the Home tab (21). The software saves a movie of the model 
rotating along the y-axis at a speed of 60°/second. The file name and location are shown in the Log panel (5) 
after the file has been saved. 
 
To prepare more sophisticated movies, you need to play with commands that move the display to a specific 
position of the model without using the mouse, thus increasing the precision and reproducibility of the display 
movement. The movement/rotation commands are applied to all selected models of the session, which can 
be identified by the check mark in the relevant column (13) of the Models panel (6). 
 
Useful commands to move/rotate the models include: 

> turn <axis> <rotation angle>  [allows the rotation of the model by a defined 
angle around a specific axis (x, y or z)] 

o e.g.: turn x 90   [rotates the model by 90 degrees around the x-axis, which is 
the horizontal axis of the displayed image]  

> move <axis> <movement in Å>  [moves the model along the defined axis, by a 
specified translation] 

o e.g.: move y -9  [9 Å movement of the model along the –y direction, i.e. 
downwards] 

> zoom <value> [zooms in on the structure, if the assigned value is greater than 1, or zooms 
out, if the assigned value is less than 1] 

> roll   [This command without further specifications continuously rotates the model around 
the y-axis, at a speed of 25°/second, producing one frame per degree.] 

> roll <axis> <rotation angle per image> <number of frames> [the model is 
continuously rotated around the defined axis] 

o e.g.: roll x 2 180 [continuous rotation of the model by 2 degrees per frame, for 180 
frames] 

> stop [This command stops the previous action, which can be, for example, the continuous rotation 
around an axis.] 

> wait <number of frames> [Pauses the action for a defined number of frames.] 
 
When separated by a semicolon, multiple commands can be executed simultaneously. On the contrary, when 
commands have to be executed one after the other, you can separate them with a semicolon followed by the 
command wait.  
 
When working on the movie of the model of interest, it is useful to save different orientations with the view 
name command:  

> view name <orientation name>. 
To recall a specific orientation, use the command view (see above). Pay attention that the view name 
command only saves the view orientation but not the displayed contents: when a view orientation is recalled 
with the view command, models are visualized/hidden as they were before reorienting them, with the same 
colors and styles previously set, and NOT with the settings on display when the view orientation had been 
saved.  
 
To start recording a movie with a specific sequence of actions, type the command: 

> movie record 
At this point you can type movement commands, such as the roll command, or the commands: 

> fly <1st orientation> <2nd orientation>  [moves the camera from the first 
view orientation to the second while saving 100 frames]  



> fly <view1> <frame number> <view2>  [as above, but with a defined number of 
frames between the two view orientations] 

> crossfade <#frames>; hide /C  [this is an assembled command: the crossfade 
command morphs between two images along the defined number of frames; at the same time, the 
hide command blurs the specified portion, i.e. chain C]. 

 
When all actions that you want to represent in the movie have been typed in, the movie has to be saved as a 
file with the command movie encode:  

> movie encode C:/<path>/<name>.mp4   
  

 
Viewing maps obtained from electron microscopy data 
The ChimeraX software allows the visualization of electron density maps (or electrostatic potential maps) 
obtained from both diffraction and electron microscopy data. The typical format for these maps is the CCP4 
format encoded in .map files. As with atomic models, to open a map use the command: 

> open #<number> fromDatabase EMDB   [which opens a map from the EM database] 
or click on the menu File > Open (2) (selecting an already downloaded file) or File > Fetch By ID (4). 
When opening the map, the software automatically opens the Volume Viewer panel (49) where the contour 
line value of the displayed map can be selected by changing the position of the bar. The same panel can also 
be opened from the menu Tools > Volume Data > Volume Viewer. Alternatively, from the command line you 
can type the command: 
 

> volume #<map ID> level #<contour level value> 
 

 
 
We often need to insert an existing model in the map (for example, when a previously determined 
crystallographic structure is available for the protein of interest and we want to interpret EM data). To this 
aim, load the file with the coordinates of the structural model. Then, the software fits the model within the 
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map using the Tools > Volume Data > Fit in the Map menu. After selecting this option, the software opens a 
panel in the main window (49) from which you can select the model to be fit and the electron density map to 
be used.  
Before proceeding with the automatic fitting, it is useful to pre-position the model within the map to obtain a 
better correspondence between model and map. This can be done by selecting only the atomic model (from 
the Models panel or from the command line, see above) and manually inserting the model in the map with the 
Move model and Rotate model actions (50) from the Right Mouse menu (51). This sequence of commands will 
allow you to move the model but not the electron density. 
 
 

 
 
Once the model has been inserted into the electron density, the Fit button (52) will perform the required 
translations and rotations of the model in order to optimize its correspondence with the electron density (53). 
The same result can be obtained with the command: 

> fitmap #<model ID> inMap #<map ID> 
 
Once the model has been inserted into the map, their correspondence can be better visualized by making the 
map transparent (54), selecting the Actions > Surface > Transparency menu and the desired transparency 
value, or with the command: 

> transparency #1 60 [sets a transparency value of 60% for map #1]. 
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