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1 Introduction
In this document, all the steps necessary to solve a fluid dynamic problem, whose geometry
is particularly simple, will be described in detail using ANSYS Fluent 2024R1® (hereinafter
Fluent for brevity). To this end, we will use ANSYS Workbench® (WB hereinafter), whose
characteristics make it particularly convenient and easy to understand the sequence of steps
used for any CFD analysis. In other tutorials, WB will not be used, for convenience, although
its use is always possible.

The chosen problem, as mentioned, is particularly simple from a geometric point of view,
and this will allow us to define the geometry directly within WB via ANSYS Design Modeler®

(DM hereafter), rather than importing the geometry generated through an external CAD. How-
ever, it is a problem with interesting characteristics:

• Flow with non-trivial peculiarities (secondary motions);

• Wide availability of experimental data, global and local;

• Accuracy, qualitative and quantitative, of the predictions strongly influenced by the
analysis methods.

It is perhaps unnecessary to point out that there are numerous analogous cases in the lit-
erature, characterized by simple geometry and non-trivial or complex motion characteristics,
which therefore lend themselves well as a topic for the student project.

2 Description of the problem
We wish to study the turbulent flow, for an incompressible fluid (water at 20 °C) and in the
absence of heat transfer, through a 90° bend (elbow) of a circular section pipe, as shown in
figure 2.

The problem data are summarized in table 1. In the table, D is the diameter of the pipe,
Um is the mean velocity of the fluid and Re is the Reynolds number.

Characteristic data of the problem.

D = 50 mm
L1 = 200 mm
L2 = 300 mm
ri = 100 mm
re = 150 mm
Um = 0.2 m/s
µ = 8.899 × 10−4 kg/(m s)
ρ = 997 kg/m3

Re = ρUm D
µ = 9980

Table 1: Data for the 90° elbow.
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2 2 Description of the problem

Figure 1: Characteristic dimensions of the 90° elbow.

In past experimental studies [1] for this problem, it was observed:

1. Possible presence of separation phenomena, both on the extrados and on the intrados,
in the latter case downstream from the point of greatest curvature;

2. Superposition, on the main motion, of a secondary current, which tends to shift the
maximum values of the velocity towards the external side, and whose origin can be
explained as follows. If the motion were irrotational, the velocity profile, uniform in
the straight section, in the curved section would present greater values towards the in-
side (convexity) and lower towards the outside (concavity). According to the principle
of conservation of mechanical energy (Bernoulli’s theorem), therefore, there would be
a progressive transformation of kinetic energy into pressure energy along the external
wall, and an opposite transformation for the internal wall. As a result of friction, how-
ever, the fluid near the walls is slower than that of the irrotational model, and therefore
both the pressure recovery on the external side, and the pressure drop on the internal
side, will be lower than the theoretical values. Compared to the situation predicted
by the irrotational model, there will be an imbalance of pressures which determines a
certain transfer of fluid from the inside to the outside of the curve.

3. The secondary current that is thus determined tends to shift the maximum values of the
velocity towards the external side, as illustrated in the experimental findings in figure 2,
and to create a double spiral motion that has important consequences: in addition to
producing a further dissipation of energy, these secondary motions extend for a very
long stretch after the end of the curve - even 40 − 60 diameters - and can significantly
distort the measurements, carried out with venturi meters, counters etc., placed at an
insufficient distance from the curve itself.
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3 Analysis with ANSYS Workbench and Fluent 3

Figure 2: Characteristics of the flow in a 90° elbow detected experimentally.

3 Analysis with ANSYS Workbench and Fluent

• Start ANSYS Workbench (WB for brevity) via the icon on the desktop, or via

Start → ANSYS 2024 R1 → Workbench 2024 R1

The WB interface will look like the one in figure 3.

• Select SI or metric units of measurement from the Units menu as shown in figure 4.
Note that it will always be possible to change this choice later, even customizing the
values of the units of measurement for each quantity, from the WB Units menu.

• Select, from the Toolbox list on the left, in the Analysis Systems group, Fluid Flow
(Fluent) and drag it into the Project Schematic pane, as shown in figure 5.

• The system in the Project Schematic pane will now appear as in figure 6, in which
you can notice that the various items, called (cells) in WB, which make up the project
scheme - Geometry, Mesh, Setup, Solution and Results - are distinguished by a question
mark, to signify the absence of data or the presence of errors.

It will now be necessary to proceed, from top to bottom, starting from Geometry and,
once completed that step, move on to Mesh, and so on. Every time a phase (cell) is
completed correctly, it will appear, instead of a question mark, with a green checkmark
symbol ( ).
At this point it is appropriate to describe the different types and states of the cells,
referring to the Help for further information.

Types of cells
The most common types of cells that occur in many of the analysis and component
systems available in Workbench are:
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Figure 3: Starting ANSYS WB.

Figure 4: Selecting measurement units in ANSYS WB.
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Figure 5: Selection of Fluent in ANSYS WB.

Figure 6: Cells status in the Fluent project.
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6 3 Analysis with ANSYS Workbench and Fluent

Engineering Data
Use the Engineering Data cell with Mechanical systems or the Engineering
Data component system to define or access material models for use in an
analysis.

Geometry
Use the Geometry cell to import, create, edit or update the geometry model
used for analysis. Right-click the cell to access these functions in the context
menu.

Mesh
The Mesh cell in Fluid Flow analysis systems or the Mesh component system
is used to create a mesh using the Meshing application. It can also be used to
import an existing mesh file.

Setup
Use the Setup cell to launch the appropriate application for that system. You
select solution methods and algorithms and define materials and boundary
conditions. The data from the application is incorporated into the project in
Workbench, including connections between systems.

Solution
From the Solution1 cell, you can access the Solution branch of your applica-
tion, and you can share solution data with other downstream systems.

Results
The Results cell indicates the availability and status of the analysis results
(commonly referred to as postprocessing). From the Results cell, you cannot
share data with any other system.

Typical Cell States

Attention Required
All of the cell’s inputs are current. However, a corrective action has to be
taken in order to proceed. To complete the corrective action, you may need
to interact with this cell or with an upstream cell that provides data to this
cell. Cells in this state cannot be updated until the corrective action is taken.
This state can also signify that no upstream data is available, but you can
still interact with the cell. For instance, some applications support an empty
mode of operation in which it is possible to enter the application and perform
operations regardless of the consumption of upstream data. This is the case,
for example, of the Geometry cell.

Unfulfilled
The required upstream data does not exist. Some applications may not allow
you to open them with the cell in this state. This is the case, for example, if
you have not yet assigned a geometry to a system: all downstream cells appear
as unfulfilled, because they cannot progress until you assign a geometry.

1Selecting Edit from the Setup cell loads grid and settings and not the current case/data file or the initial data
file. To load the current or initial data file, select Edit from the Solution cell instead.
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3 Analysis with ANSYS Workbench and Fluent 7

Refresh Required
The upstream data has changed since the last Refresh or Update and it may
or may not be necessary to regenerate the output data. When a cell is in this
state there are generally several options:

– Edit and review the unrefreshed data.
– Refresh the data, but without incurring any time-consuming operations,

such as generating a new mesh if the geometry has changed.
– Update the cell, which will result in a Refresh and regeneration of the

data, such as generating a new mesh if the geometry has changed.
The advantage of being able to perform a Refresh, instead of an Update, con-
cerns the possibility of obtaining diagnostic information on the downstream
cells without performing a real Update, potentially much more expensive in
terms of time and computational resources.

Attention Required
All of the cell’s inputs are current. However, a corrective action has to be
taken in order to proceed. To complete the corrective action, you may need
to interact with this cell or with an upstream cell that provides data to this
cell. Cells in this state cannot be updated until the corrective action is taken.
This state can also signify that no upstream data is available, but you can
still interact with the cell. For instance, some applications support an empty
mode of operation in which it is possible to enter the application and perform
operations regardless of the consumption of upstream data. This is the case,
for example, of the Geometry cell.

Update Required
The local data of the cell has been modified and therefore the output of the cell
must be regenerated. When updating a cell that requires Refresh, the Refresh
operation will be performed first, followed by Update.

Up to Date
An update has been performed on the cell and no failures have occurred. It
is possible to edit the cell, and for the cell to provide up-to-date data to other
cells.

Input Changes Pending
The cell is up to date, but its state may change as upstream cells are updated.

Solution-Specific States
The Solution or Analysis cell for certain solvers can display the following solution-
specific states.

Interrupted, Update Required
The solution has been stopped correctly: the solver has completed its iteration
and produced a solution file. This file can be used for post-processing - for
example to verify that the solution is proceeding towards a physically correct
result - or to restart the solution, using the Resume or Update functions.

Pending
Signifies that a batch or asynchronous solution is in progress. When a cell
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8 3.1 Geometry generation

enters the pending state, you can interact with the project to exit Workbench
or work with other parts of the project. If you make changes to the project
that are upstream of the updating cell, then the cell is not in an up-to-date state
when the solution completes.

Failure States
If a particular action fails, Workbench provides a visual indication as well. You can
pane any related error messages in the Messages pane by clicking Show Messages
in the lower right portion of the window.

Refresh Failed, Refresh Required
The last attempt to refresh cell input data failed and the cell remains in a
refresh required state.

Update Failed, Update Required
The last attempt to update the cell and calculate output data failed and the cell
remains in an update required state.

Update Failed, Attention Required
The last attempt to update the cell and calculate output data failed. The cell
remains in an attention required state.

• In the meantime, let’s save the WB project in the chosen working folder (it is advisable
to use a separate working folder for each project), by selecting the Save Project as icon

from the menu bar or from File → Save as, and name it ElbowFluent (the extension
.wbpj, from WorkBench ProJect, will be assigned automatically), as in figure 7.

Figure 7: Saving and naming the project.

3.1 Geometry generation

• In geometry generation, there are more ways to reach the same result: the choice, in
addition to being dictated by experience, depends on numerous factors, such as:

– Ease of subsequent grid generation, and quality of the latter;

E. Nobile, R. Zamolo - April 2025



3.1 Geometry generation 9

– Geometry parameterization, for subsequent parametric analysis, optimizations,
etc.;

– Export of the results to other products and/or other physics (e.g. fluid-structure
interactions).

Figure 8 shows the adopted order of generation of the elements.

Figure 8: Order of generation of the elbow geometric elements.

• Right-click on the Geometry cell and select New DesignModeler Geometry from the
menu, as shown in figure 9. Please note that double-clicking directly on the Geome-
try cell, corresponds to select a New SpaceClaim Geometry, i.e. the default geometry
system. DM will start and you will need to select the unit of measure of lengths, as

Figure 9: Starting ANSYS Design Modeler.
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10 3.1 Geometry generation

shown in figure 10. Choose mm (selecting, in the checkbox, Always use project units,
will always use the unit of measure of length previously chosen in WB).

Figure 10: Choice of length measurement unit in ANSYS DM.

• Select the YZ plane in the left tree and, with the right mouse button, select the Look at
option to move the view on the plane itself.
Then click on the New Sketch icon ( ), located at the top, and rename the sketch (right
mouse button) to Diameter. The DM window will appear as in figure 11.

Figure 11: Generation of the sketch Diameter.

• Move to the Sketching menu on the left and select Circle in the Draw submenu, as
shown in figure 12. At this point:

– Position the mouse pointer at the origin of the axes until the letter ’P’ appears,
indicating the option to snap to the point;
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3.1 Geometry generation 11

Figure 12: Selecting the Circle item in the Draw submenu in Skeching.

– Press the left mouse button, drag it radially and finally release it to define the
radius;

– Select the Dimensions submenu to parametrically define the diameter value;

– Select the Diameter option;

– Move the mouse over the circumference;

– Click with the mouse to associate the D1 dimension to the geometric entity;

– In the Details menu on the left, type the diameter value, 50 mm, in the appropriate
box.

The final result is shown in figure 13.

• In the Modeling tree, select the sketch to extrude (Diameter), and:

– Click on the Extrude icon at the top;

– Rename the extrusion to UpstreamPipe, similarly to what was done with the sketch;

– Set the extrusion direction to Reversed;

– Set the extrusion depth (Depth) to 200 mm;

– Click on the Generate icon , present in the top menu.

The result is illustrated in figure 14, in which the choices indicated are highlighted.

• Return to the YZ plane again and:

– Generate a new sketch, to be renamed to Axis;
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Figure 13: Diameter selection.

Figure 14: Generation of the pipe section upstream of the elbow.
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3.1 Geometry generation 13

– Select the Sketching tools and from the Draw menu click on Line;

– Draw a horizontal line below the circumference, keeping the left mouse button
pressed. To do this, make sure that there is a letter ’H’ near the line, to indicate
that the line is arranged horizontally: the result will be as in figure 15;

– Go to the Dimensions menu and select a vertical dimension;

– Click on the line to be quoted, just drawn, and on the horizontal axis of the cir-
cumference - the Y axis - to define the dimension;

– Define, as previously, the correct value of the quota, equal to 125 mm, as illustrated
in figure 16.

Figure 15: Horizontal axis for the sketch Axis.

• Select the Revolve modeling option, indicated by the symbol .

– Rename the feature to Bend;

– In the detail window, at the bottom left, associate the Diameter sketch to Geom-
etry, and the Axis sketch to Axis (after selecting the Axis sketch with the mouse,
simply press Apply to associate it with the rotation axis);

– Set, always in the detail window, the revolution angle to 90°;

– Click on Generate: the result will be as in the figure 17.

• Rotate the pipe so as to bring the surface downstream of the elbow to the foreground,
and select it, as depicted in figure 18.

• Once the face is selected, you need to:
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Figure 16: Quotation of the horizontal axis.

Figure 17: Generation of the elbow.
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Figure 18: Selection of the face downstream of the elbow.

– Generate a new Extrude feature, renaming it DownstreamPipe, similarly to what
was done previously with UpstreamPipe;

– In the detail window, associate the selected surface to Geometry and as direction
vector select the XY Plane in the Tree Outline;

– Set the extrusion direction to Reversed;

– Define an extrusion depth equal to 300 mm;

– Click on Generate to generate the feature.

The result is illustrated in figure 19.

• In the Modeling tree on the left, click on 1 Part 1 Body, and rename the corresponding
solid as pipe, as shown in figure 20. Finally, is useful to set - or check - that, clicking on
the pipe in the tree Outline, it is set as fluid in the Details View below, as also illustrated
in figure 20.

• While not strictly necessary in our case, we save the geometry just completed with the
name ElbowGeometry: the extension .agdb, Design Modeler DataBase files, will be
assigned automatically, as shown in figure 21.

• Close Design Modeler.

• In the main project window (Workbench), save and update the entire project.
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Figure 19: Generation of the pipe downstream the bend.

Figure 20: Renaming the solid as pipe and set it as a fluid domain.
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Figure 21: Saving the geometry.

3.2 Generation of the computational grid

• In the main window, position the mouse on Mesh in the project scheme by right-clicking
and selecting Edit, as in figure 22, or double-click with the left button.

Figure 22: Launching ANSYS Mesh.

• Once ANSYS Meshing has started, the result will be as in figure 23.

By clicking on Mesh, in the tree on the left of the project, the information reported in
the detail window on the left, reproduced in figure 24, will be displayed. In particular,
you will notice that CFD is indicated as Physics Preference, while Fluent is selected by
default as Solver Preference, without the need for further information.
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Figure 23: ANSYS Mesh splash screen.

Figure 24: Details about Preferences in ANSYS Mesh.
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• It is now appropriate, before proceeding with the actual generation of the grid, to appro-
priately name all the boundary surfaces of the domain - patches - thus facilitating the
subsequent imposition of the boundary conditions. As shown in figure 25, right-click
on Model → Insert → Named Selection in the top left tree.

Figure 25: Inserting Named Selection into ANSYS Mesh.

Next:

– Rename to Inlet;

– Select the entry face to the pipe upstream of the bend, recognizable by its position
with respect to the coordinate axes (for convenience: the shortest branch);

– Press Apply, as shown in figure 26.

Proceed in a similar manner for the exit section (face), naming it Outlet, as in figure 27.

It is finally necessary to define the pipe wall, renaming the region to Wall, as illustrated
in figure 28, paying attention to the fact that the wall is actually made up of 3 surfaces:
to choose multiple surfaces you need to hold down the Ctrl key during the selection.

• It is useful to observe that Fluent recognizes typical naming conventions on boundaries,
such as inlet, outlet, far-field, symmetry, wall, interior, or internal. More precisely,
the changing of Fluent boundary types based on name patterns is controlled by an ad-
vanced option, which is enabled by default. When enabled, the following most common
patterns and corresponding zone types are applied on all zones:

– inlet maps to a velocity-inlet zone
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Figure 26: Definition of the Inlet face in ANSYS Mesh.

Figure 27: Definition of the Outlet face in ANSYS Mesh.
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Figure 28: Definition of the Wall faces in ANSYS Meshing.

– outlet maps to a pressure-outlet zone

– symmetry maps to a symmetry zone

– far*field maps to a pressure-far-field zone

– mass*inlet maps to a mass-flow-inlet zone

– press*inlet maps to a pressure-inlet zone

– mass*outlet maps to a mass-flow-outlet zone

– outflow maps to an outflow zone

– inlet*vent maps to an inlet-vent zone

– outlet*vent maps to an outlet-vent zone

– intake*fan maps to an intake-fan zone

– exh*fan maps to an exhaust-fan zone

– fan maps to a fan zone

– porous*jump maps to a porous-jump zone

– radiator maps to a radiator zone

– overset maps to an overset zone

• Once the definition of the regions is complete, we can proceed to the generation of
the meshes by adopting the default settings for what concerns the information on the
minimum and maximum dimensions of the cells, the grid generation algorithm etc. This
information can be found by clicking on Mesh → Default and Sizing in the tree on the
left, as shown in figure 29.
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Figure 29: Default values for sizing in ANSYS Mesh.

In order to generate the mesh, you need to click on the Generate Mesh icon ( )

available under the Home tab in the main menu, or the ( ) available under the Mesh
tab, and wait the time necessary to complete the operation.

The progress of the grid generation will be indicated by the waitbar present in the lower
left corner of ANSYS Mesh and shown in figure 30. In this case since, as we will see,
it is a rather coarse mesh, the time needed is rather small, while in the case of complex
geometries and high resolution, the time needed can be of the order of hours, depending
also on the computing platform.

Figure 30: Grid generation progress in ANSYS meshing.

The resulting grid, which will be displayed in the main window at the end of the gener-
ation, is shown in figure 31.

The grid thus obtained, clearly, is too coarse to adequately describe the phenomenon: it
is sufficient to observe, by clicking on Statistics in the bottom left menu, that the total
number of nodes is equal to 4482, and the total number of cells (remember that ANSYS
Fluent is a Cell-Centered Finite Volume type code), is equal to 3526.

Therefore, it is necessary to modify (reduce) the default values for Sizing, appropriately
reducing the size of the cells. For example, by bringing both the values of Element
Size, which sets the global maximum mesh size on surfaces, and Max Size, which sets
the global maximum mesh size within volumes, to 5 mm (5×10−3 m), as illustrated in
figure 32, the mesh of figure 33 is obtained.

• It is possible to note, however, that also this grid is probably inadequate, especially with
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Figure 31: Grid obtained, in ANSYS Mesh, using the default values for the Sizing.

Figure 32: Setting reduced values for Sizing in ANSYS Mesh.
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Figure 33: Grid obtained, in ANSYS Mesh, using the values of Sizing of figure 32.

regard to the wall resolution. We will return to this aspect later. It is worth remembering
that, every time changes are made, it is necessary to Update the mesh, in addition to
updating any references to the mesh by other cells, in our case the Setup cell. This is

done either by clicking Update ( ), instead of Generate Mesh ( ) in DM, or by
right-clicking the Mesh cell in WB and selecting Update, as shown in figure 34

Once the mesh generation is complete, we can now close ANSYS meshing (from File →
Close meshing) and proceed with the Setup of the problem, but not before saving the
entire project in WB (File → Save).

3.3 Problem setup
• In the main window, position the mouse, in the WB project scheme, on the Setup cell

by clicking with the right button and select Edit, as in figure 35.

Once the Setup is started, the Fluent Launcher window will appear, as depicted in fig-
ure 36. In this window, select Double Precision and a number of Solver Processes equal
to 1 or 2.2

When the launch of ANSYS Setup will be completed, the result will be as shown in
figure 37.

• It is now necessary to proceed with the setting of all the parameters and models con-
cerning the simulation, and in particular:

2It is important to remember that the number of solver processes has to be always less than the number of the
physical cores of the machine where Fluent runs.
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Figure 34: Update of the Mesh cell in WB.

Figure 35: Starting ANSYS Setup.
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Figure 36: Fluent Launcher window.

Figure 37: ANSYS Fluent Setup initial screen.
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3.3 Problem setup 27

– Analysis type (steady or non-steady) and solver type (pressure-based or density-
based);

– Presence of rigid body motions (dynamic mesh);

– Characteristics of the computation domain;

– Presence of sub-domains;

– Thermophysical properties of the materials;

– Boundary conditions;

– Interfaces (overset meshes);

– Solver parameters and schemes;

– Initialization;

– Output and monitor options;

– Grid adaptivity;

– Execution parameters.

In the Graphical User Interface (GUI) of ANSYS Fluent, the ribbon, located at the top
of the Fluent GUI, is the primary method for setting up and running the simulation. It
facilitates access to the most commonly used items, with tabs nominally arranged in a
left to right workflow for a typical simulation. Contents within each tab are grouped
with related content and are organized logically to accommodate varied projects and
priorities. There is the option to minimize the ribbon by clicking ( ), located to the
right of the ribbon tabs.

It will therefore be useful and convenient to follow this order to prepare the launch
of the simulation, with the warning that it is not necessary to set the irrelevant items,
which should therefore be left at their default values (e.g. in this case there are no rigid
body motions, no sub-domains, no interfaces, and furthermore we do not activate the
adaptivity of the grid).

• In order to display the mesh lines in the graphic window, there are two options: you
either click the Display button located in the Mesh tab of the ribbon ( ), or the
analogous button located in the toolbar of the graphics window. In both cases, a window
like in figure 38 will show up, and it will be necessary to tickmark the Edges checkbox.
The result will be as shown in figure 39.

Please note that, in order to maximize the graphic window, it is possible to collapse
both the Task Page and the Outline View, located at the left of the graphic window, by
clicking the Collapse buttons ( ) located on top of both windows.

• The first step to do is to check that the mesh is correct and that it corresponds to our
system. In order to do so, click the Check → Perform Mesh Check button in the Domain
tab of the ribbon. This action will provides a mesh check report, displayed in the console
window located below the graphics display, with details about domain extents, statistics
related to cell volume and face area, and information about any problems associated
with the mesh. In our case the output should be like this
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Figure 38: Set Fluent mesh display options.

Figure 39: Fluent mesh shown in graphics window
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Domain Extents:

x-coordinate: min (m) = -2.000000e-01, max (m) = 1.500000e-01

y-coordinate: min (m) = -2.500000e-02, max (m) = 2.500000e-02

z-coordinate: min (m) = -4.250000e-01, max (m) = 2.500000e-02

Volume statistics:

minimum volume (m3): 5.408590e-09

maximum volume (m3): 1.384248e-07

total volume (m3): 1.358336e-03

Face area statistics:

minimum face area (m2): 1.081718e-06

maximum face area (m2): 3.842509e-05

Checking mesh.....................................

Done.

• A second check to do consists in a quick evaluation of the mesh quality. To do it, click
on Quality → Evaluate Mesh Quality button in the Mesh tab of the ribbon, shown in
figure 40.

Figure 40: Check Mesh Quality in Fluent

The result of this check, in our case, is this

Mesh Quality:

Minimum Orthogonal Quality = 4.61947e-01 cell 14488 on zone 2 (ID: 29573

on partition: 0) at location ( 1.18191e-01, -5.68914e-03, -7.60437e-02)

Maximum Aspect Ratio = 1.26192e+01 cell 9705 on zone 2 (ID: 29551 on

partition: 0) at location ( 3.34879e-03, -5.68914e-03, 2.88517e-03)

It is useful to remind that a more comprehensive evaluation of the quality of the mesh

can be done with ANSYS Mesh, clicking on the Metric Graph button ( ) located
in the Mesh tab of the ribbon and selecting the mesh metric desired, i.e. Aspect ratio,
Skewness, Orthogonal quality et.

• It is convenient, for our purposes, to use mm as length unit. To do so, click on the Units
button ( ) also located in the Domain tab of the ribbon. This will open a new
window, where it will be possible to select the units of measurement for each physical
quantity. In particular, for length we select mm, as shown in figure 41.

It is important to note that, when you read the mesh into Ansys Fluent, it is always
assumed that the unit of length is meters.
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Figure 41: Set length unit in Fluent.

• It is now necessary to proceed to the definition of the parameters of the problems, and
in sequence:

1. Select the Physics tab of the Fluent ribbon.

2. Check that, in the Task Page, the solver selected is the Pressure-Based with Abso-
lute Velocity Formulation and that the Steady formulation is chosen, as indicated
in figure 42

Figure 42: Solver selection in Fluent Task page.

3. Click Models in the Setup tree branch on the left, and check that in the Models
window that will appear, all the options are set to off, but the Viscous model, that
should be set to SST k-omega, as shown in figure 43. If this is not the case, clicking
on Viscous under the Models tab of the ribbon, you will be able to select the
appropriate turbulence model for our problem, as illustrated in figure 44. Please
note that, since in this case there is not heat transfer, the Energy equation entry
should be set to off.

4. We have now to set up the material for our problem. We have to use the same
values of the thermophysical properties reported in table 1.
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Figure 43: Checking the active models in Fluent.

Figure 44: Set the viscous model in Fluent.
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In the Materials group of the Physics ribbon tab, click on Create/Edit ... icon( ).
In the Create/Edit Materials dialog box that will appear, type water for Name and
in the Properties group enter the values of density and dynamic viscosity given in
table 1. Click Change/Create and the result will be as in figure 45. A Question

Figure 45: Inserting water properties in the Create/Edit Materials dialog box in Fluent.

dialog box will open, asking if you want to overwrite air. Click Yes, in order to
avoid any possible confusion later, e.g. only water will be used as a fluid (note that
this will affect only the local copy of material properties).

5. In the Zones group of the Physics ribbon tab, click on Cell Zones. This will open
the Cell Zone Conditions dialog box3. In the dialog box, only one zone should be
visible, the one named pipe. Select it, and verify that in the type drop-down list
it should be set to fluid. Click Edit to open the Fluid dialog box and Check that,
on the Material Name drop-down list, water is selected. Click Apply to close the
Fluid dialog box.

6. It is now necessary to setup the boundary conditions for the problem. In the same
Zones group of the Physics ribbon tab, click on Boundaries. This will open the
Boundary Conditions task page4. It is convenient to display the boundary zones
grouped by Zone Type: this can be achieved by clicking the Toggle Tree View
button in the upper right corner of the Boundary Conditions task page, and under
the Group By select Zone Type from the drop-down menu, as shown in figure 46.

(a) Set the boundary conditions at the (fluid) inlet.
From the Zone selection list, select inlet, for the Type select velocity-inlet and
click Edit. As illustrated in figure 47, in the Velocity Inlet dialog box, set the
Velocity Magnitude equal to 0.2 m/s, and leave all other parameters for the

3Please note that the same dialog box can be opened by double-clicking the Cell Zone Conditions under the
Setup tree branch on the left.

4Please note that the same task page can be opened by double-clicking the Boundary Conditions under the
Setup tree branch on the left.
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Figure 46: Boundary conditions grouped by Zone Type in Fluent.

Momentum tab as the default. Click Apply to close the Velocity Inlet dialog
box.

Figure 47: Inlet boundary condition as velocity-inlet in Fluent.

(b) For the outlet, select outlet from the Zone selection list, for the Type select
pressure-outlet and click Edit. As illustrated in figure 48, in the Pressure
Outlet dialog box, leave the Gauge Pressure equal to 0 Pascal, check the Av-
erage Pressure Specification and leave all other parameters for the Momentum
tab as the default. Click Apply to close the Pressure Outlet dialog box.

(c) For the wall, select wall from the Zone selection list, for the Type select wall
and click Edit. Verify that, in the Momentum tab, it is set as a No Slip, Sta-
tionary Wall, as depicted in figure 49.

3.4 Solution
Select the Solution ribbon tab and then:

1. Click on the Solution Methods icon ( ).

2. This will open the Solution Methods task page: leave all the choices as their default
values, like in figure 50. Please note that the second order upwind scheme is selected
by default for momentum and turbulent quantities.
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Figure 48: Outlet boundary condition as pressure-outlet in Fluent.

Figure 49: Wall boundary condition in Fluent.
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Figure 50: Solution methods selection in Fluent.

3. In the Reports group, click the Residuals icon ( ). This will open the Residual
Monitors dialog box and on this:

(a) Check that, in the Options group, Print to Console and Plot are enabled.

(b) Change the values for the Convergence Absolute Criteria from 0.001 to 1 × 10−4

for the continuity, the velocity components, turbulent kinetic energy and omega,
as illustrated in figure 51.

4. It is a recommended practice to monitor physical quantities relevant to the problem
at hand, in addition to equation residuals, when judging convergence. These physical
quantities can be, for example, the force or drag for an external aerodynamics problem,
or, like in this case, the pressure loss for an internal flow problem et. For this purpose:

(a) We first define two surfaces, one just before the bend and one immediately after:
select the Results ribbon tab and, in the Surface group, click Create → Plane...
and, in the corresponding window that will open up, name the surface as up-
streamplane, as the Method select YZ plane and type 0 mm as X value. Click
Create.
Operate in the same way for the downstreamplane, but in this case select XY Plane
as Method and insert −125 mm as Z value.
Figure 52 illustrates the definition of the two planes.

(b) On these two surfaces, we define the values of the - weighted-averaged - pressure
values. For this purpose, on the main ribbon, under the Solution tab, select Def-
initions → New → Surface Report → Area-Weighted Average . . . , as depicted in
figure 53.
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Figure 51: Convergence criteria in the Residual Monitors dialog box in Fluent.

Figure 52: Upstream and downstream surfaces definition in Fluent.
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Figure 53: Definition of an Area-Weighted average Surface Report in Fluent.

On the window menu that will open, reported in figure 54, insert pressupstream
as the name, Pressure and Static Pressure as Field Variable, checkbox the Report
File and Report Plot under Create and select the upstreamplane under Surfaces.

Repeat the same procedure for the pressure downstream, selecting pressdown-
stream as the name, and downstreamplane as the surface.

(c) It is now finally w the ∆P we want to monitor during the calculation in order to
establish that convergence has been achieved.
Select again Definitions → New → Expression. In the Expression Report Defini-
tion window that will open up, first set deltap as name and select Functions →
Mathematical and then abs. Inside the abs(<expr>) insert Report Definitions and
then ”pressureupstream - pressuredownstream”, as illustrated in figure 55. In this
case, besides to checkbox Report File and Report Plot, we also checkbox Print to
Console.

5. Before launching the calculation we have to initialize the solution: check that, in the

Initialization group, the selected method is Hybrid, and click the Initialize icon( ),
as shown in figure 56. After the initialization is completed - it will take around ten
iterations - we are ready to start the calculation.

6. As a last step before the calculation, we can ask Fluent to check for potential problems:
in the Run Calculation... group of the Simulation tab, click the Check Case button and,
if no problems are found, the response should be like in figure 57.

7. In the Run Calculation... group of the Simulation tab set the No. of Iterations to, say,

E. Nobile, R. Zamolo - April 2025



38 3.4 Solution

Figure 54: Definition of an upstream pressure Surface Report in Fluent.

Figure 55: Definition of the pressure loss ∆P in Fluent.

Figure 56: Initialization task in Fluent.

E. Nobile, R. Zamolo - April 2025



3.4 Solution 39

Figure 57: Fluent check case result.

500 and click the Calculate icon( ).5

The calculations will start and the graphic windows will display either the residual val-
ues or, if selected, the pressure drop ∆P . The calculation will take at most few minutes
depending on the hardware available, and will complete in about 130 iterations. The
reduction of the residuals and convergence of ∆P will be as in figure 58.

(a)

(b)

Figure 58: Fluent calculation completed: (a) Residuals reduction; (b) ∆P convergence.

5Irrespective of the maximun number of iterations set, the calculation will stop when either one of the follow-
ing conditions are first met: the residual values are all below their target or the maximum number of iterations
have been reached. In any case, it will be possible to restart the calculation from the actual state without losing
any information.
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3.5 Visualization and post-processing of results

It is now possible to proceed with the visualization and post-processing of the results. These
activities can be done either within Fluent or in Results, the ANSYS post-processor. In what
follows, we will use the former option.

1. We may first visualize the pressure field: in the Outline View, Results group, select
Graphics, Contours and New.... In the Contours window that will open up, rename
it pressurecontour, then select Pressure, Static pressure as variable, and wall as the
corresponding surface, as shown in figure 59.

Figure 59: Fluent Pressure contour options.

Click Save/Display and the result will be as in figure 60.

Figure 60: Pressure field on the elbow wall.

From the figure, the pressure loss within the elbow is evident, as well as the higher
pressure along the external side of the pipe in comparison to the internal side.
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2. In order to visualize the secondary motions, in the Outline View, Results group, select
Graphics, Pathlines and New.... In the corresponding Pathlines window that will open
up, select, as in figure 61, inlet in the Release from Surfaces list, and keep all other
options as their default. Click Save/Display and the result will be as in figure 62.

Figure 61: Fluent Pathlines options.

Figure 62: Visualization of secondary motions.

However, although the secondary motions are perceptible - it is sufficient, for this pur-
pose, to observe the spiraling trend of the streamlines downstream of the curve - it is
preferable to change the point of view to highlight them better. To do this, first click
on the Projection icon ( ), and select Ortographic Projection, and then on the −z axis
of the triad (it is sufficient to click the z axis twice to obtain the view from −z). The
result is illustrated in figure 63, which makes the existence of secondary motions very
evident.
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Figure 63: Clear visualization of secondary motions from −z.

3. Secondary motions can also be visualized by displaying velocity vectors. To do this,
select again Graphics in the Results group, and then Vectors → New.... In the Vectors
window that will open up, as shown in figure 65:

• insert vectordownstreamplane as Vector Name;

• select downstreamplane in the Surfaces list;

• select arrow as style;

• set 10 as Scale value;

• click the Vector Options button: in the window that will pop up, deselect the Z
Component, click Apply and then Close, as illustrated in figure 64.

Figure 64: Fluent vector visualization options.

Click the Save/Display botton and the result, after selecting the view from −Z, will be
as depicted in figure 66.

4. The vector velocity plot clearly indicates the presence of secondary motions, however,
it is not easy to compare them with the experimental findings given in figure 2. For this,
it is preferable to visualize the velocity contour plot in the downstreamplane, in analogy
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Figure 65: Selection of Fluent vector features.

Figure 66: Visualization of secondary motions by means of vector plot.

to figure 2. To do so, in the Outline View, Results group, select Graphics, Contours and
New.... In the corresponding Contours window that will open up, rename it as velocity-
contour and select, as in figure 67, Velocity... as Contours of and downstreamplane in
the Surfaces pane, and keep all other options as their default. Click Save/Display and
the result will be as in figure 68 where, for convenience, also the experimental contours
are provided in order to facilitate the comparison.

5. The velocity field obtained numerically certainly resembles the experimental one, how-
ever there are some differences.

6. A more quantitative analysis - that might constitutes one of the objectives of the simula-
tion - is the evaluation of the pressure drop ∆P , a quantity that we have already defined
and used in monitoring the convergence of the calculation. In this case it is a localized
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Figure 67: Fluent velocity contour options.

(a) (b)

Figure 68: Velocity contour on the downstreamplane: (a) experimental; (b) computed.

pressure drop, which is usually expressed with a relation like

∆p = K
1

2
ρU2 (1)

where the empirical coefficient K is a function of

• rc/D ratio, with rc radius of curvature of the elbow axis (see figure 2);

• surface type, smooth or rough;

• Reynolds number.

The value of ∆P can be obtained by clicking, with the right mouse button in the Out-
line View, Solution → Report Definitions → deltap and then Compute, as depicted in
figure 69.
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Figure 69: Compute the pressure loss ∆P in Fluent.

Doing so, it results that ∆P = 4.63 [Pa]. We can now compare this value with the
experimental data available in the open literature. The comparison is summarized in
table 2.

Pressure drop ∆P [Pa]

Present CFD 4.63

A. Ghetti (1977) [2] 3.50
White (2010) [3] 3.99
Ito (1960) [4] 5.76

Table 2: Comparison between the calculated pressure drop value and those reported in litera-
ture.

It can be noticed that our computed value of ∆P is in general agreement to the - some-
how scattered - values from the literature, thus confirming the overall correctness of our
simulation.

4 Improved accuracy
Although our results are generally in agreement with the experimental results available in
the literature, they are certainly not free from errors and inaccuracies. Although we are not
looking here for results free of convergence errors and grid-independent (aspects that are fully
covered elsewhere), we might certainly improve the quality of our simulation by considering
the following aspects (not necessarily in order of importance).

4.1 Geometry modifications
One may notice that the elbow geometry is symmetric respect the x–z plane6. For this reason,
it is computationally convenient to perform the simulation for only half elbow. This can be

6It may be additionally noted, in figures 63 and 66, that both the streamlines and velocity vectors are also
symmetric respect the x–z plane: this is reasonable and may be expected, since we have used a steady RANS
model.
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easily obtained, in Design Modeler, by selecting, in DesignModeler Menu Toolbar, Tools →
Symmetry, as shown in figure 70.

Figure 70: Selecting the Symmetry tool in DesignModeler.

After that, as illustrated in figure 71 in the Symmetry Details View, select the ZXPlane as a
symmetry plane, and press Generate.

Figure 71: Choice of the Symmetry plane in DesignModeler.

The resulting modified geometry is shown in figure 72.
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Figure 72: Modified geometry (half elbow) in DesignModeler.

4.2 Grid improvements
The grid, how we noticed before, is still inadequate, in particular for the resolution close to
the wall. It can be improved, by:

1. Reducing both the Element Size and the Max Size to 2.5 mm (2.5× 10−3 m).

2. Adding an inflation layer, to better capture the boundary layer close to the walls, as
depicted in figure 73.

Figure 73: Adding an Inflation Layer in ANSYS Mesh.

In the Details menu on the left, as shown in Figure 74, verify that the Scoping Method
is set to Geometry Selection, and select the face corresponding to the inlet section as
the Geometry. Similarly, verify that the Boundary Scoping Method is set to Geometry
Selection, and specify the edge of the face just selected as the Boundary. In this case,
a reasonable choice would be to set to 12 as the number of Maximum layers, to select
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the First layer Thickness as Inflation Option and set it to 0.2 mm (0.2 × 10−3 m) and a
Growth rate to 1.2.

Figure 74: Details of the Inflation Layer in ANSYS Mesh.

3. Insert a Method for generating the mesh, and setting it to Sweep Method, as indicated in
figure 75. After this, clicking on Sweep Method in the outline tree in the left, will open
up the Details window on the left, where one should make the following selections, as
shown in figure 76:

(a) Select Geometry Selection as Scoping Method.

(b) Select the Body of the elbow as Geometry.

(c) Select Sweep as Method.

(d) Select Program controlled as Algorithm.

(e) Select Manual Source and Target as Src/Trg Selection. This means that the elbow
will be discretized, along its axis, starting from the Source, in this case the inlet
face, towards the Target, i.e. the outlet face. Select them, respectively, as Source
and Target in the Details window.

(f) Select Number of Divisions as Type and 200 as Sweep Num Divs.

(g) Leave all other selections as their default value.

Once these steps are complete, visualize the mesh by clicking Generate Mesh. The final
finer mesh, which has about 212.00 cells and 220.00 nodes, is illustrated in figure 77.

Figure 75: Inserting a mesh generation Method in ANSYS Mesh.
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Figure 76: Inserting the generation Method features in ANSYS Mesh.

Figure 77: Final, finer mesh obtained in ANSYS Mesh.
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4.3 Model and Setup modifications
1. To guarantee a better convergence towards the solution, it is reasonable to reduce the

residuals level from 1 × 10−4 to 1 × 10−5 for the continuity, the velocity components,
the turbulent kinetic energy and omega (ω), as illustrated in figure 78.

Figure 78: Reduced residual values in the Residual Monitors dialog box in Fluent.

2. In the previous, low-resolution calculation, we have assumed that the velocity at the
inlet was constant, e.g. a flat profile. This is, however, an unrealistic assumption:
a better choice would have been, for example, to set again a constant velocity value
at the inlet and provide a longer inlet pipe, such as to allow for a complete dynamic
development of the velocity profile before the curve 7. This approach, unfortunately,
is rather inconvenient and computationally expensive, since for a circular pipe with a
value of the Reynolds number of about 10× 103, the dynamic development length is of
the order (10− 60)D [5, 6], with experimental data [7] indicating a value ≈ 30D.

3. A better, more realistic approach, would consider to assign a fully developed velocity
profile at the inlet. There are several formulas for the turbulent, fully developed velocity
profile for smooth circular tubes, see e.g. [6] for the most common, but in our case,
since we provide an inlet pipe where the velocity profile may somehow adjust to this
problem, it is sufficient to consider one of the simpler ones, due to Prandtl [8]:

U

Umax

=

(
y

D/2

) 1
n

(2)

Um

Umax

=
2n2

(n+ 1) (2n+ 1)
(3)

7The flow is said to be dynamically fully developed if the velocity profile no longer changes with increasing
x, e.g. the distance from the inlet section. The distance from the entrance at which this condition is achieved is
termed the hydrodynamic entry length, xfd,h.
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where, in eq. (2), Umax is the maximum value of the velocity at the centreline, U is the
local value of the velocity and y is the radial distance measured from the duct wall.
The exponent n varies slightly with Re (see [6] for further details), and in our case it
can be assumed n ≈ 6.2.
Therefore, from (3), it results Umax = 0.251 [m/s], and eq. (2) can be inserted directly
- or using the expression editor - as inlet boundary condition in Fluent, as shown in
figure 79.

Figure 79: Setting a velocity profile as inlet boundary condition in Fluent.

Once all these improvements and modifications are done, the calculation can be repeated
and the result is ∆P = 4.67 [Pa], a value that differs by less than 1 % from the result obtained
previously with a coarser grid and different inlet boundary condition.

However, by comparing the velocity contour on the downstreamplane obtained now with
that obtained previously on the coarser grid, as depicted in figure 80, it is clear that the higher
resolution provided by the new mesh allows a more realistic prediction of the velocity field
(compare these plots with the experimental contour of figure 2).

5 Concluding Remarks and Further Activities
As has been demonstrated, the overall accuracy of numerical results depends on the numeri-
cal simulation settings (the convergence criterion), on the modeling choices (a fully developed
velocity profile at the inlet rather than an unrealistic flat velocity profile), and on the quality
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(a) (b)

Figure 80: Velocity contour on the downstreamplane: (a) coarser grid; (b) refined grid.

and resolution of the computational grid. There is also the issue of modeling error, not ad-
dressed in this simple tutorial. Among the possible activities left to the interested student, we
highlight:

• Use of other turbulence models, such as, for example, the Realizable k − ε model or a
Reynolds Stress Model (RSM).

• Evaluation of the Convergence error.

• Analysis of Grid independence, i.e. identify the minimum level of grid resolution which
guarantees a grid-independent solution.

• Repeat the calculation on a block-structured computational grid.
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